Linux clients behind relayd bridge not working

hey,

I just started to use Openwrt on my second router to get an Wifi Bridge working because my cable broke. I use the following Configuration with 192.168.0.1 as my main ap with dhcp server and so on. My windows Client work behind the OpenWRT Router, so do my android devices. Yet my Linux client cant connect to it neither with wifi nor with an ethernet cable attached.

config interface 'stabridge'
        option proto 'relay'
        option ipaddr '192.168.0.2'
        list network 'lan'
        list network 'wwan'

config interface 'wwan'
        option proto 'dhcp'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.1'
        option dns '192.168.0.1'
        option stp '1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '78:11:dc:42:e4:78'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

Wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '0'
        option channel '10'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option ssid 'Main AP'
        option network 'wwan'
        option mode 'sta'
        option encryption 'psk2'
        option key 'mypassword'

config wifi-iface 'repeater'
        option device 'radio0'
        option ssid 'LEDE'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key 'mypassword'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

I dont know what could be wrong. Please Help

Best regards

Are you sure relayd is working? I could not see any relay interface in that network configuration...
Also, you should try to debug the issue and be a bit more specific: instead of "my Linux client cant connect to it", you could tell us what is not working: does it get an IP address? is the IP address within the expected range? does it get a DNS? does it work? can it ping an outside server? ...?

Yes relay should be working. It should be the "stabridge" interface. I followed this guide:
Wifi Extender or Repeater or Bridge Configuration
In my main AP(192.168.0.1) which is running stock Tp-Link Firmware i reserved the address 192.168.0.199 for the Client. It is wired like that:
Tp-Link---WirelessBridge--- OpenWRT --- Switch --- Client

The Client gets the the following settings assigned:
IP:192.168.0.199
Subnet: 255.255.255.0
Broadcast: 192.168.0.255
which is correct

ping from 192.168.0.1 and 192.168.0.2 (openwrt router) get timed out - same the other way round
Also cannot ping outside servers e.g. 8.8.8.8

the device gets registered as "Unknown" in the TP-Link router although i changed the name in dhcpcd.conf everything else untouched.
The thing is... im just writing from a pc connected to the same switch and my android tv is also working fine at that same switch.

@Calle -- I don't have network.lan.stp option and instead of the list, I set the interfaces for stabridge as an option (with uci set network.stabridge.network="lan wwan"), and short of disabling IPv6 that have pretty much the same config and have a bunch Linux clients working just fine over wireless repeater.

Are you sure some network settings are not hardcoded/preset in your Linux clients?

Sorry, I could not see the "stabridge" section, even if I looked there twice...

May I ask why are you changing the MAC address on the eth0.1 interface? It is not the same as the Linux device, is it?

I would also make sure that the Linux computer is properly configured.

@stangri
I just followed your tips and disabled stp. which had no effect. I Also set network.stabridge.network="lan wwan" which also had no effect.

@eduperez
I didnt even change it myself. It happens to be the same as the wifi 2.4 Ghz adapter, so i guess it has come with stabridge.

--- 192.168.0.199 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

my linux client interfaces file:

# interfaces(5) file used by ifup(8) and ifdown(8)
# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

and dhcpcd.conf

# A sample configuration for dhcpcd.
# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
MYSQLPI

# Use the hardware address of the interface for the Client ID.
clientid

# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.
#duid

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name option classless_static_routes
# Most distributions have NTP support.
option ntp_servers

# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

also the output of ifconfig on my client

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
inet 192.168.0.199  netmask 255.255.255.0  broadcast 192.168.0.255
ether b8:27:eb:4a:bd:01  txqueuelen 1000  (Ethernet)
RX packets 133837  bytes 6648714 (6.3 MiB)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 24157  bytes 1732067 (1.6 MiB)
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536   
inet 127.0.0.1  netmask 255.0.0.0
loop  txqueuelen 1  (Lokale Schleife)
RX packets 18  bytes 1710 (1.6 KiB)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 18  bytes 1710 (1.6 KiB)       
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0