Linux 802.11s batman-adv mesh

Hello all and thank you for your help in advance!

Problem/Task: I try to add my Raspberry pi (Raspbian Lite) to an existing mesh-network that uses batman-adv for routing. According to some tutorials, it's pretty easy, you just have to execute the following commands as root:

ip link set up dev wlan0
iw dev wlan0 del
iw phy phy0 interface add wlan0 type mesh
ip link set up mtu 1524 dev wlan0
iw dev wlan0 mesh join meshID
batctl if add wlan0
ip link set up dev bat0

Question: what is my "meshID"? On my router (OpenWRT) I have the following Configuration of the router. So is the "meshID" the one of the Mesh Point ("mesh2G") or is it the one of the AP ("DS-IoT-Mesh")?


Personal opinion: try to stick with ssh and vim and the OpenWrt this might be easier then fiddling with the web GUI.

Thank you a lot!

Now, that I have re-written my SD-Card (to start from the beginning), iw dev wlan0 del gives me "command failed: Unknown error 524 (-524)". But I have to delete it in order to create the Mesh Point.

Under iw list. I can see that phy0 supports mesh Point, but as long as wlan0 exists, I can't create it...

Does Raspian use NetworkManager or any other means of "fancy"/"modern" network auto configuration? (I want to ensure that nothing else tries to handle the phy0.)

Is wlan0 present and configured? What does ip link show?
What happens if you just try to execute iw phy phy0 interface add wifimesh type mesh?

Edit: PS: Please share the blog/guide/whatever you try to follow...

I think that there is a network manager available but I don't make use of it (not on purpose).

It is a clean installation of Raspbian where I execute ip link set up dev wlan0 and iw phy phy0 interface add wifimesh type mesh. But ip link set up mtu 1524 dev wlan0 fails, because the "Network name is not unique" (because wlan0 is still present).

This would be the tutorial

Is you wifi device really named wlan0? Because (my impression is) you follow the first part where the dude sets up the mesh on OpenWRT...
As your mesh is already present continue with the next part, and this is disable networkmanager. Or configure NM to only handle eth0 or whatever your ethernet is named...
Then try again to delete the wifi device

Sorry for my late answer, I was ill until today.

The error was that I mixed up phy0 and phy1 and tried to configure the onboard-wifi as a mesh node (and Raspberry Pi 3 onboard doesn't support that)...
Now, that I changed that, the connection to the Mesh-network works.

Thanks a lot! I'll mark this question as solved and open a new one (about how to bridge the mesh-network to an access-point)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.