Linksys WRT32x -- DDWRT ok. Stock firmware not working

So basically i tried to flush the firmware with ExpressVPN WRT3200ACM, and somehow it bricked the router original firmware. now it is booting into DDWRT but i cant seem to access the stock firmware anymore. if i try to update the firmware via GUI to linksys official it wont do the flush. it completes successfully but the firmware remains DDWRT.
i connected the Serial connection via serial cable [not ttl] and the bootloader is not giving me values in English. there are strange characters, for which i am uploading a screenshot.
i thought maybe just serial wont do it so i bought TTL cable the PL2303, first off when i connect the TTL cable, the router won't boot up at all. there is just one LAN light powering on. but no responce on Putty. after playing with the connections for a bit i plugged RX into the first connector where the ground was supposed to be and i saw the same messed up text in putty.
i am not sure if the boot loader is corrupt as i can login to DDWRT pefrectly if i turn on the router.
can someone please help me flush stock formware on both partitions. i am a bit stuck here.

Thank you!


1 Like

Dear Frollic, i am thankfull for the link. i am however new and i dont know how that works. i can upload screenshots of putty not working. i am not very good with code.
this is all i see in putty.
here is a link to the entire log file from putty.

thank you

If some OS boots, you don't really need the serial port, yet. Follow dd-wrt instructions to return to stock. Flash stock twice so that both partitions contain stock. Then install OpenWrt.

If you currently have access to DDWrt the easiest thing to do would be to boot into the other partition and see what it contains using the commands found in the second comment of this thread, you'll just need to enable ssh which I believe is found in the Services tab (although it's been a while since I've used DDWrt so I may be mistaken) and then use Putty for the commands.

1 Like

first of all Thank you for the replies, this is a friendly place to be. :slight_smile: :innocent: here is what i have done, though the GUi tab in DDWRT, i have tried like 10 times to flash the firmware with the stock linksys as well as OPenWRT, everything goes perfectly fine until the reboot. upon reboot its back to DDWRT and no other firmware is there. its like nothing is written to the flash. i have tried this several times. as for the other partition i have turned off and on the router more than three time consecutively as instructed it will only boot into DDwrt. as a last resort i am trying via serial. remind you the router is booting perfectly into DDWRT. but its seem like it wont let me overwrite DDWRT.
Thank you

Since you are having problems with dd-wrt, you should ask your question in the dd-wrt forum.

please move the thread accordingly.

Please mind: OpenWrt forum != DD-WRT forum. You have to go over to and create a new topic there.

1 Like

sure. thank you i will try now. this conversation thou, have some useful info and some details about my problem :frowning:
i am sorry my account over there is not active yet :frowning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.