Linksys WRT3200ACM - Unstable connection to access point in 2.4 ghz band


I have problems with getting a stable wifi connection over the 2.4 ghz band.

Configuration radio0:
Operating frequency:
Mode: AC
Channel: auto
Width: 80 MHz
Transmit Power: auto
Interface Configuration:
Mode: Client (WDS)
Wireless Security:
Encryption: WPA2-PSK
Cipher: Force CCMP (AES)

Configuration radio1:
Operating frequency:
Mode: N
Channel: 6
Width: 40 MHz
Transmit Power: auto
Interface Configuration:
Mode: Acess Point
Wireless Security:
Encryption: WPA2-PSK
Cipher: Force CCMP (AES)

radio2, which is normally used for DFS, is disabled. Furthermore, the wireless interfaces are bridged together with the ethernet switch ports to one single interface.
Now, the internet connection of the wired clients is no problem, but the clients that are connected to the Access Point at 2.4 ghz have constant disconnects. I already disabled "Disassociate On Low Acknowledgement". Does anyone know a solution?

What's the other router in the WDS setup? And how far apart are they?

The other router is a FritzBox 4040 and they are about 5 meters apart.
Before I switched to the WDS solution, I had configured it as a simple client to the FritzBox and had setup a simple routing between this interface and a bridge interface containing the switch and the 2.4 ghz access point. But with this setup I had constant network freezes over all the interfaces, so I switched to WDS.

Well, your FritzBox 4040 is QC-based and WRT3200ACM is Marvel-based, so issues in WDS between the two isn't a surprise, I think.

I know that WDS is a technique which is not very reliable between different devices certainly not between devices from different manufacturers but the clients which are connected to the ethernet ports of the linksys router don't have any problem with its internet connection, only the client clients that are connected to the 2.4 ghz access point.
Until now I didn't find any stable solution to connect to the FritzBox in the 5 ghz band and connect separate clients over the 2.4 ghz band.

And using the 5 GHz got the AP is not feasible, I imagine, as you probably have clients that don't support that?

But just to identify where the problem is, have you tried connecting the two routers by cables, ruling out the WDS of completely, and see if you still have issues with the 2.4 GHz AP?

You may also want to mention the OpenWrt version you are using, in case there were any known issues with any version.

Yes, I have connected both routers by wire and the problem still exists.
I use the last stable build 18.06.4.
Linksys also offers a mode called "Wireless Bridge" in its official firmware and there I also used the 5 ghz band for bridging and the 2.4 ghz band for access point and everything worked well.
I know, never touch a running system, but I installed a raspberry pi with kea dhcp and a dynamic DNS zone through bind9 and this broke my setup. From until then dhcp requests were not longer answered because auf the way Linksys handles broadcasts in its OEM firmware.
Before OpenWrt I also tried dd-wrt but it was less reliable than OpenWrt. But until now I haven't found any reliable solution where I can use the 5 ghz band for "upstream" and the remaining interfaces as "downstream".

So it's safe to put the link between the two routers aside and just conclude that the problem is with the 2.4 GHz band.

I don't own the device or have specific knowledge of it, so hopefully someone else does. But meanwhile, did you try different channel or 20 MHz bandwidth, in case thee is some interference?