Linksys WRT3200ACM - No link on WAN port

Good day.
I'm having issues with setting up a stock install of OpenWRT on the mentioned router.

My setup is ISP Fibre Optic Modem (an old ZTE) -> WRT3200ACM -> rest of the network.

Installation goes through fine, and networking on the LAN ports works as well after changing the router IP from 192.168.1.1 to 192.168.2.1 (DHCP hands out IP addresses, and I am able to ping between machines). However at this point I have no Internet connection, the WAN interface has no IP and is shown as not connected. If I connect other devices directly to the ZTE they get an IP address and are able to connect to the internet. The 3200 seems to be the only device having this issue. Everything worked pretty seamlessly on the Linksys firmware. I have tried to both a static address mode and a DHCP client mode on the 3200, with the same result. I've tried both the stock OpenWRT 18.06.1, as well as the dc502 build.

Here is my /etc/config/network (this is the post installation default, aside from the LAN static ip change):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc7:ac9f:45c3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'
        option vid '2'

Any help with this is appreciated

How is the firewall configured?

Along with checking the firewall, I think you're missing dns and gateway in config interface 'lan'if I'm understanding your setup correctly, point both to the ip of your modem, so -

config interface 'lan'

option dns '192.168.1.1'
option gateway '192.168.1.1'

replace 192.168.1.1 with whatever your modems ip is.

@mike, I'mot sure you are, the OP's issue is with the WAN port. Assigning a gateway on LAN will cause issues if WAN is in use.

  • If WAN is in use (implied by the thread's title), a gateway config should be done there.
2 Likes

Ahh thanks, I'll leave it so there won't be any confusion in the thread, but please ignore the dns and gateway suggestion @panda_madness.

Sorry for the delay, I was forced to switch back to stock to get some work done.

Here are the contents of /etc/config/firewall:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

config include 'bcp38'
        option type 'script'
        option path '/usr/lib/bcp38/run.sh'
        option family 'IPv4'
        option reload '1'

Could you please try again, but with "bcp38" disabled?
Also, I would like to see the logs of the router trying to acquire an IP address.

BCP38 seems to be disabled?

I've rebooted the router and got the syslog from LuCI, hope this is what you meant.
https://pastebin.com/m3R0sJCg

I want to mention that I've changed the initial config slightly: rather than changing the OpenWRT routers' LAN subnet from 192.168.1.1 to 2.1, I've changed the ISP modem's LAN to 192.168.0.1

Everything seems fine to me... it looks like the router is sending DHCP requests, and not receiving any answer, but I cannot explain why.

Can you get any logs from the upstream server, and see if it is receiving and answering the DHCP requests?

Is there anything at "/etc/firewall.user" that could be blocking DHCP? Could you dump your firewall rules and post them here?

Perhaps "tcdump" could confirm that the packets are going out but the answers are not arriving.

I just experienced exactly this problem, and got Googlepointed to this post to find a solution.

It was the Ethernet cable between the WRT3200ACM and the modem, a flat black cable that I think came with the modem. Replaced it, and everything started to work properly.

Funny thing, no matter how the WRT WAN port was configured (StaticIP, DHCP Client, PPoE) the existence of the WRT was recognized by the modem (Bell Home Hub 2000). But neither StaticIP nor DHCP would bring up an IP address, and with DHCP there seemed to be some kind of packet storm (so everything else connected to the modem stopped working). Of course, PPPoE never worked (the modem was not in bridged mode).

Even stranger, the very same cable worked just fine with the same WRT but a different Bell Home Hub 2000 modem.

One of these days I'm going to cut that cable into little pieces.

--Bob.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.