Linksys WRT3200ACM (BT Full Fibre broadband)

I have installed the latest OpenWRT onto the router via the developer interface. I am now unable to connect to the modem via WiFi to access the interface or to connect to it via SSH. Any help would be kindly appreciated?

the whole WRT series currently has some issues with all of the 21.02 RC releases. There are several issues still in progress.

the one bug that likely affects your issue is: 21.02-rc3 on WRT3200ACM wireless 5GHz not working - #7 by anomeome

I would recommend to go back to 19.07 for a while and try again when RC4 or release attempt, but might be good idea to first check the forum. 21.02 unfortunately was not a piece of cake for Linksys WRT so far.

good thread for tracking status might also be Maybe also check the latest messages there, scanning for WRT notes. I might not be up to date how far issues are resolved in latest snapshot release already for WRT.

(But make sure you know, how to switch firmware partitions and rollback on WRT, before attempting any snapshot deployments, to avoid having 2 half-working firmware partitions deployed)

Thanks Pico. I simply manually installed the firmware via the manufacturer UI. Not too sure how I can access the modem now?

Wifi is disabled on a new installation. Connect a computer by Ethernet to one of the LAN ports and it should obtain an IP address of 192.168.1.X. The router is If you installed a snapshot build the only access method is ssh. If you installed a release or RC build the web interface is also available.

1 Like

best is to carefully read and use one of the „firmware recovery“ methods available on WRT:

this will get you in the other working partition. From there I would flash latest 19.07.

when flashing, the currently booted partition will always flash the other partition, leaving the currently booted partition unaffected. Thats why I would not start a flash from the now half-working 21.02. partition

I've been able to access my modem via ethernet, which is a good start. I'm guessing I need to download the firmware version that you've mentioned and install it to the router, right?

on Linksys WRT devices you have a second partition which holds your previously used firmware. I personally would first switch to that other partition with the linked description, before attempting the next flash attempts.

Otherwise you are currently booted in the half working 21.02 partition and would overwrite the other (sane) partition when flashing. That bears a risk of ending with both partitions being in a non fully sane state. In worst case you would brick the router ( which is difficult on WRT, since it has lots of recovery options). But since you are not very familiar with it, I would go the safest way:
Just try the on/off switch method described.

Then you can install the LuCI GUI with these commands from the SSH console:

opkg update
opkg install luci

And WRT3200ACM is no "modem".
It is a router without any modem functionality.

Thanks, guys. I've been able to set up the WIFI now, which is a good start! Where am I able to add my BT Full Fibre broadband information to set up the internet?

It appears to be a pppoe connection, so go to network-interfaces-wan and change the protocol to pppoe and enter the username and password.

1 Like

Thank you! All seems to be working fine now. Are there any settings that you recommend I should change to optimise my setup better?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.