Linksys WRT3200 on Sky Fibre: Clients disconnect in IPv6 bridge / relay mode


I've recently installed OpenWrt 19.07.2 latest release to my WRT3200 and am configuring to my needs. I have an issue with my IPv6 configuration which I cannot seem to fix so am reaching out to the community for help.

My set up is: WAN: Sky Q Hub -> LAN: (DMZ) Linksys WRT3200 -> Plume wireless APs (bridge mode) -> clients

The vanilla OpenWRT configuration provides stable wired and Wi-Fi connections to all client types (mix of Windows, Linux, Android and iOS). However because my WRT3200 router sits behind a Sky Q hub gateway, IPv6 on the LAN doesn't work for me out of the box.

To get IPv6 to work I have configured the LAN and WAN interfaces for use with the Sky Q hub following the bridge / relay method. IPv6 is not 100% reliable when I test connectivity and I start to regularly lose wireless connections to Android and iOS clients which then immediately reconnect. It is frustrating (sometimes reconnect up to every few minutes, but I cannot see any obvious patterns e.g. I am not roaming between APs in the house). Windows client Wi-Fi connections seem stable on both vanilla and IPv6 OpenWRT configurations.

It must be a misconfiguration somewhere but I'm new to IPv6 and can't figure it out - please help! Once I've fixed this I'll add DDNS, DOT and WIreguard, but I want to be sure either IPv6 will work for me, or if it's a Sky issue then I'll forget it and look at IPv6 at a later time.

Here is my network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd33:9333:1986::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask ''
        option ip6assign '60'
        option ipaddr ''

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'static'
        option netmask ''
        option ipaddr ''
        option gateway ''

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'
        option peerdns '0'
        option reqprefix '56'
        option reqaddress 'try'

And DHCP config:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/'
        option localservice '1'
        option domain 'homenet.local'

config dhcp 'lan'
        option interface 'lan'
        option leasetime '12h'
        option start '129'
        option limit '100'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option ndp 'relay'
        option ra 'relay'
        option dhcpv6 'relay'
        option master '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Configuration for relay is correct.
However I would leave the reqprefix to auto and not 56, in case the SkyQhub delegates prefix.

1 Like

Thanks for the response. I've reverted back setting and will monitor for a day to see if that has any positive impact.

Unfortunately the change to auto reqprefix has made no difference after gateway and router reboots and 12+ hours running, and my Wi-Fi clients are still being disconnected and reconnected throughout the day unsolicited. Would anyone be able to point me in the right direction to fault find further (e.g. increase the logging level of dnsmasq DHCP errors, or other configuration checks I can make)?

Thanks again for your support!

I just wanted to confirm that once I had fixed another issue logged here I decided to revisit my IPv6 config and reenabled the relay settings as above. Now I don't get any connection issues at all and IPv6 is working as expected.

I don't really understand why but both issues seem related for my set up. Anyway thought I would update in case it helps anyone else in the future.


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.