Linksys wrt310n-v2 with LEDE

Hello. I am a student who studies SDN in Korea.

I would like to replace the firmware provided by Linksys with a LEDE. So i downloaded the image file for my router from OpenWrt. And, i installed the image file on my router. However, i got an error message that is "the file transferred is not a valid firmware image".

in this case, what should i do?

please leave a comment.

Please provide the make and model of your router. It seems you tried to flash via the OEM upgrade screen in the web GUI. With some devices, that will not work.

Try using TFTP...

Should work with either stock or open source firmware.

Note that 2.4 Ghz is only partially supported for the WRT310N v2.[Model*~]=wrt310&dataflt[Versions*~]=v2

Thank you for your reply.

The model for my router is Linksys WRT-310N.

I've tried a few things.

I tried to replace the firmware with a previous version. But it made the same error message.
I tried TFTP, but I couldn't access my router.

What's the problem?

Thank you for your reply.

According to your advice, I used TFTP. However, I could not access the router.

Make sure the TFTP program has access through the firewall.

With the firewall turned off or turned on, i have used two methods to try to access router.

However, I received the same error that I could not access my router.

Can you SSH in to the router?


Oh! Yes!! i received that message!!

I know you got the message...please answer the questions above.

Ping react. But, i can't ssh

Are you able to access the Linksys stock firmware web GUI?

Yes, i can access.

What program are you using to SSH?

What error do you get?

I use Putty program to ssh.
I received error message that is "Connection refused."

The older Cisco/Linksys routers had SSH capability, the newer Belkin/Linksys routers do not.

Try changing the file extension to .trx on the LEDE firmware file, and flash from the Linksys GUI.

I received "The image file is incorrect."
And i found one solution that if i get that error i have to change cfe boot loader.
Do you know something about this solution?

That requires a serial connection and is probably the next step.

If you don't have a USB to TTL serial cable, you'll need to get one.

ok! Thanks for your help!

A couple of things you might consider going forward...

  1. The WRT310N v2 only has 4 MB of flash. You won't be able to use LuCI (the GUI) and the performance and stability may be affected.

  1. Wireless functionality is limited due to the Broadcom chip.

So instead of risking a brick on your router that may wind up not being as useable as you would like with OpenWrt/LEDE, you might stick with stock firmware, and consider another router.

I would still recommend getting a USB to TTL serial cable for future use, if needed.