Linksys WRT1900ACV2 can't connect to Internet

Hello everyone! I've been using openwrt on my linksys wrt1900acv2 for quite some time. and when I finally switch to LEDE after the flashing process and everything went well the router boot up and I went to the status page of the router, it was not able to connect to the Internet. And I waited 15 minutes to make sure if it was able to pick up an ip address but nothing and I tried the same process rc 1 and rc 2 and the problem still persists that my router is not able to connect to the Internet. Can someone please help me? Also when I wanted to downgrade to the openwrt image I was using I had to do it through the serial cable because when I went to flash on the GUI it wouldn't let me proceed saying that it wasn't a compatible image. And also thank you for reading! Also I almost forgot to mention I have followed the cannot connect to Internet troubleshooting faq and still nothing.

How do you connect to the Internet? Static address, DHCP, or PPPoE?

Try restart the modem if you have them in front of your router (cable modem, dsl modem or fiber device)


how is the wan port configured? Which type of internet connection do you have? DSL, cable, LTE???
So many questions and so little information.


Oops I'm sorry I forgot to include that information. But i have Verizon fios and I connect through dhcp. And I have tried restarting the ont (fiber device) and waited for some time and still nothing. And the wan port I do not touch I just leave it as is. When I flashed back to openwrt it picks up an ip address instantly so it is at is default configuration. And so I assumed it would have been the same with LEDE.

I get this when I google:

An update I'm not sure whether is good or bad but I managed to get an ip address but thing is that I tried to install bcp38 and I wasn't so I used the - - force-depends option and installed it then afterwards i tried to into the router but instead got this:

/usr/lib/lua/luci/dispatcher.lua:518: Invalid controller file found
The file '/usr/lib/lua/luci/controller/bcp38.lua' contains an invalid module line.
Please verify whether the module name is set to 'luci.controller.bcp38' - It must correspond to the file path!
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:518: in function 'createindex'
/usr/lib/lua/luci/dispatcher.lua:544: in function 'createtree'
/usr/lib/lua/luci/dispatcher.lua:220: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:141: in function </usr/lib/lua/luci/dispatcher.lua:140>

But afterwards the router was able to get an ip address and everything but I cannot access the luci router page. So I tried to remove and reinstall luci and still I'm not able to access the web page but I am able to ssh into the router. So I'm not sure when I forced the installation of luci-app-bcp38 it may have downloaded something for the router to gain an ip address I'm not sure... Also I was surprised that I was able to even update packages when entering opkg update and it went through but I was not able to connect to the Internet before installing bcp38