Linksys WRT1900acs WiFi

Hey,
I am having trouble configuring properly my new router wifi(apparently) - currently the wifi(both 5ghz and 2.4ghz) range is way smaller than my old Linkysys wrt54gl(the wifi of the wrt54gl was usable 10m away from my porch 2 floors down - diagonally looking).
Both WiFi channels barely reach my porch, both of them barely usable - if usable at all.

The router is located 30cm beneath the ceiling on a wooden shelf, all antennas straight up - marked as a red on the attached image.
Wifi signals marked on the image -> blue = 5ghz, pink 2.4ghz (i did some iperf test, didnt save the results.. i can repeat them if it would help debug my issues)

My current wireless config:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option bursting '1'
        option ff '1'
        option compression '1'
        option noscan '1'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'SI'
        option channel '36'
        option htmode 'VHT80'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '5a:ef:68:b7:4d:32'
        option ssid 'Cool name'
        option key 'superpass'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option country 'SI'
        option channel '9'
        option bursting '1'
        option ff '1'
        option compression '1'
        option noscan '1'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option hwmode '11g'
        option legacy_rates '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '5a:ef:68:b7:4d:31'
        option key 'superpass'
        option encryption 'psk2'
        option ssid 'Cool name 2.4'

I tried to fiddle around with the configs(width, channel,...), so far this was the best i could do on my own.

final notes:

  • the old router was running openwrt, and had probably more than 20dbm tx power
  • my neighbors aren't close, their wifis are visible in some corners of the house with around -95dbm
  • currently only one possible problem goes trough my mind - the walls that are thicker on the attached image, "main carrier walls", made out of bricks as far as i know..
  • running Lede 18.6.1 with latest Wifi drivers from here: https://github.com/eduperez/mwlwifi_LEDE

Thanks for any possible tip

WifiFloor

This is a different device (also incapable of N speed)...the true test is if the WRT1900ACS works at the same distance as the WRT54GL on stock firmware?

You could add to config wifi-device 'radio0':

option txpower 'X'

Not sure why the performance seems to be worse than the WRT54GL

On the antennas, I would not have them all standing straight up so that they get "more different" signals and some of the advanced features of modern 802.11 potentially can be more effective. \ | / is one "not too ugly" setup. You might also try one vertical, one horizontal "to the south" and one horizontal "to the east" (right angles between all). Still, while a good thing to explore, that's probably not the cause of your problems.

Take a look at you location. I was very surprised to find that the seemingly good spot for one of my Archer C7s, up high on the top of a bookshelf, its base ~45 cm from the ceiling, wood-frame construction was actually the source of the throughput problem I was just chasing down on 2.4 GHz with one device in my network!

Edit: Also check if it's on a metal shelf or metal chassis of another box -- current units many times use "patch" or other internal antennas for 2.4 GHz. The WRT54 series used the "rubber duckies" as another difference to "current" units.

Up high:

image

Not only slow, but "stutters" pretty severely.

Same router just on my desk:

image

Edit: 30 Mbps is my upstream limit


Legacy rates can slow down the whole network. Unless you've got some really ancient hardware, you might want to set

option require_mode 'g'

on your 2.4 GHz radio and

option require_mode 'n' # iPhone 5 can't support 802.11ac

on your 5 GHz radio (as the comment in my config indicates, the iPhone 5, unfortunately, doesn't support 802.11ac).

Your issues are resulting from a sub-optimal wifi configuration

  • option channel '36'
    • 5GHz networks should be configured with the highest channel available to it, preferably in the 150s, and definitely not below channel 72.

  • option legacy_rates '1'
    • Remove entirely... For b/g/n clients, they should be on the 2.4GHz network.
      • If you have no AC clients, but do have N clients with a 5GHz radio, switch it to N, but never Legacy.

  • Add distance and transmit values, such as:
    • option distance '50'
      • Value depends on environment
    • option txpower '20'
      • Value depends on environment

  • All wifi-iface's should have:
    • option encryption 'psk2+ccmp'
    • option wpa_disable_eapol_key_retries '1'
1 Like

added both of these features, and re-positioned the antennas.. not much improvement so far

I tried manually setting the channel to 140(max allowed on my setup), and the wifi just doesn't come up.. snippet from syslog:

Wed Sep  5 20:50:09 2018 daemon.notice netifd: Network device 'wlan0' link is down
Wed Sep  5 20:50:10 2018 daemon.notice netifd: radio0 (6061): command failed: Not supported (-95)
Wed Sep  5 20:50:10 2018 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Wed Sep  5 20:50:10 2018 kern.debug kernel: [  849.100403] ieee80211 phy0: change: 0xffffffff
Wed Sep  5 20:50:10 2018 kern.info kernel: [  849.178623] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Wed Sep  5 20:50:10 2018 kern.info kernel: [  849.185658] br-lan: port 2(wlan0) entered blocking state
Wed Sep  5 20:50:10 2018 kern.info kernel: [  849.190993] br-lan: port 2(wlan0) entered disabled state
Wed Sep  5 20:50:10 2018 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Wed Sep  5 20:50:10 2018 kern.info kernel: [  849.196434] device wlan0 entered promiscuous mode
Wed Sep  5 20:50:10 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:10 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:11 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:11 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:11 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:11 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:13 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:13 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:13 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:14 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:14 2018 daemon.notice hostapd: handle_probe_req: send failed
Wed Sep  5 20:50:15 2018 daemon.notice hostapd: Channel 144 (secondary) not allowed for AP mode
Wed Sep  5 20:50:15 2018 daemon.warn hostapd: wlan0: IEEE 802.11 Configured channel (140) not found from the channel list of current mode (2) IEEE 802.11a
Wed Sep  5 20:50:15 2018 daemon.warn hostapd: wlan0: IEEE 802.11 Hardware does not support configured channel
Wed Sep  5 20:50:15 2018 daemon.err hostapd: Could not select hw_mode and channel. (-3)
Wed Sep  5 20:50:15 2018 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->DISABLED
Wed Sep  5 20:50:15 2018 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Sep  5 20:50:15 2018 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Wed Sep  5 20:50:15 2018 daemon.notice hostapd: wlan0: AP-DISABLED
Wed Sep  5 20:50:15 2018 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Wed Sep  5 20:50:15 2018 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started

set legacy_rates to 0, added encryption and max allowed tx power(20) to the config

The only option that i managed channel 140 to work was with a width of 20mhz, and the speed was 1/3 of the channel 36 with 80hz..
Channel 100 worked with 80hz, and the speed seemed to be better

more info.. if relevant:

root@LEDE:/etc/config# iw reg get
global
country 98: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country FR: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0
country FR: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2247 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports T-DLS.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 2:
                Capabilities: 0x106f
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 4 usec (0x05)
                HT TX/RX MCS rate indexes supported: 0-23, 32
                VHT Capabilities (0x33837930):
                        Max MPDU length: 3895
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        SU Beamformer
                        SU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: MCS 0-9
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5180 MHz [36] (20.0 dBm)
                        * 5200 MHz [40] (20.0 dBm)
                        * 5220 MHz [44] (20.0 dBm)
                        * 5240 MHz [48] (20.0 dBm)
                        * 5260 MHz [52] (20.0 dBm) (radar detection)
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (27.0 dBm) (radar detection)
                        * 5520 MHz [104] (27.0 dBm) (radar detection)
                        * 5540 MHz [108] (27.0 dBm) (radar detection)
                        * 5560 MHz [112] (27.0 dBm) (radar detection)
                        * 5580 MHz [116] (27.0 dBm) (radar detection)
                        * 5600 MHz [120] (27.0 dBm) (radar detection)
                        * 5620 MHz [124] (27.0 dBm) (radar detection)
                        * 5640 MHz [128] (27.0 dBm) (radar detection)
                        * 5660 MHz [132] (27.0 dBm) (radar detection)
                        * 5680 MHz [136] (27.0 dBm) (radar detection)
                        * 5700 MHz [140] (27.0 dBm) (radar detection)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (disabled)
                        * 5765 MHz [153] (disabled)
                        * 5785 MHz [157] (disabled)
                        * 5805 MHz [161] (disabled)
        valid interface combinations:
                 * #{ AP } <= 16, #{ mesh point } <= 1, #{ managed } <= 1,
                   total <= 16, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

oh.. one last things, tried to do iw reg set my country code.. didnt work

It appears that you're in France (or at least your OpenWrt router thinks you are). Looking at the permitted channels for 5 GHz, some of the "prime" ones that US users are used to configuring aren't available. DFS ("radar detection") may be pushing your radio off the configured channel, as it is legally required to do in most jurisdictions. You should be able to see what channel the radio is using in the output of iwinfo.

There has been some evidence that certain OEM firmware does not comply with the current DFS requirements and allows operation on "occupied" DFS-restricted channels. While I'd be surprised if this is the case with a router that claims "802.11ac" from a well-respected manufacturer, it's an outside possibility.

Have you tried relocating the router to, for example, your dining table (assuming it isn't metal) or "in the clear" in one of your bedrooms?

Not yet, will do that on the weekend. Now i managed to get the 5ghz working if i choose channel 136, width 80mhz.. after the radar detection goes trough, the router picks channel 100 - the speed of 5ghz improved :slight_smile:

edit: now it jumped from channel 100 to 52
edit2: now it jumped to 36.. even though the selected channel is 136

:frowning_face: Yep, looks like you've got radar limiting what you can use. That is "typical" behavior as it leaves a channel as soon as it detects radar.

Looking at the graphic illustration of channel numbers at http://www.revolutionwifi.net/revolutionwifi/2013/03/80211ac-channel-planning.html, the channel numbers you reported, and the posted output of iw phy, it looks like your 80-MHz configuration choices are probably 36, 52, 100, 116. Since I see 144 as "disabled", I don't think you can use 132, as it would span up through 144, as I understand it. Regrettably, it appears that the "high-power" (27 dBm) channels are all "in use" by radar, so it's pushing you down to 36, where the power limit is 20 dBm.

1 Like

oh god damn it, the luck that i have :smiley:. On the wrt54gl you could youst over-ride the country and thats it :joy:

Than the only thing left to do is to try various router positions i guess...

This is the config i ended up with:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option bursting '1'
        option ff '1'
        option compression '1'
        option noscan '1'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option legacy_rates '0'
        option require_mode 'ac'
        option country 'SI'
        option htmode 'VHT80'
        option channel '136'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr '5a:ef:68:b7:4d:32'
        option ssid 'Wifi'
        option key 'pass'
        option encryption 'psk2+ccmp'
        option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '9'
        option bursting '1'
        option ff '1'
        option compression '1'
        option noscan '1'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option hwmode '11g'
        option require_mode 'g'
        option legacy_rates '0'
        option txpower '25'
        option country 'SI'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr '5a:ef:68:b7:4d:31'
        option key 'pass'
        option encryption 'psk2+ccmp'
        option ssid 'Wifi 2.4'
        option wpa_disable_eapol_key_retries '1'

iwinfo

wlan0     ESSID: "Wifi"
          Access Point: 5A:EF:68:B7:4D:32
          Mode: Master  Channel: 52 (5.260 GHz)
          Tx-Power: 20 dBm  Link Quality: 41/70
          Signal: -69 dBm  Noise: -84 dBm
          Bit Rate: 433.3 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "Wifi 2.4"
          Access Point: 5A:EF:68:B7:4D:31
          Mode: Master  Channel: 9 (2.452 GHz)
          Tx-Power: 20 dBm  Link Quality: 49/70
          Signal: -61 dBm  Noise: -87 dBm
          Bit Rate: 41.8 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 11AB:2A55 11AB:0000 [Marvell 88W8864]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

If device is a shelby v2, you are SOL as the locale data is embedded in the eeprom. There is some hope to be had given the banter in issue#280, and if you roll your own there is a patch that may offer some respite.

If possible, shouldn't channels under 72 should be avoided on the 5GHz network, as channels >13 - <72 are normally utilized for N on the 2.4GHz network (or do I have an incorrect understanding)?

I thought that was just in the US due to the FCC?

Channels 36-165 are all in the 5 GHz range (5 MHz increment per channel number). See, for example, https://www.radio-electronics.com/info/wireless/wi-fi/80211-channels-number-frequencies-bandwidth.php or the output of iw phy posted above.

1 Like

Unless this includes inside a faraday cage it seems unlikely it will help. Radars put out pulses of power in the range of megawatts (peak envelope power) and have hundreds of kilometer ranges, the difference between one end of your house and the other is negligible on the scale of hundreds of kilometers.

Best thing is going to be choose a channel that doesn't require DFS.

1 Like

I wouldn't try to move the router around to get less radar interference.. i was "debugging" if there are issues in the surroundings of the router(walls, shelf,...)

Gotcha, I'm not sure why this thread popped up as recommended just now, didn't notice the dates, seems like by now you'd probably got things figured out.

Having same issue. Did anyone managed it out?

Did you manually choose a channel that doesn't require DFS?

1 Like

The solution for me was to set it to a channel that didn't overlap "always", so most of the time its fine.. sometimes it resets automatically to a "lower" channel and stays there...

Can you paste your config please? I can't manage to turn 5Ghz on

Please post your /etc/config/wireless, removing the passphrase from the config.