Linksys wrt1900acs upgrade from factory.img to sysupgrade.bin fails

On a linksys wrt1900acs v1 my intent is to keep stock fw on one partition and have openwrt on the second partion.
Initially, the router had only the stock fw on both partitions. No non stock fw had ever been installed. From the stock fw, I installed openwrt-19.07.4-mvebu-cortexa9-linksys_wrt1900acs-squashfs-factory.img with no problem. I logged in via luci and looked through the interface. Then connected via ssh (using PuTTy) and used fw_printevn to see which partition openwrt had installed to. It was part 2. Used fw_setenv to return to part 1 on reboot. After rebooting I was back in the stock fw and then unstalled openwrt-19.07.4-mvebu-cortexa9-linksys_wrt1900acs-squashfs-sysupgrade.bin. But when the router rebooted or attempted to reboot I should say, I could not access the os via luci or ssh.
The power light has a steady blinking light at about 1 per sec. The lan port light for the port I am connected to is on.
I was able to get back to the stock fw on part 1 using the multi power on / off method. From there I did a reinstall of the ...factory.img and upon reboot, it came up without an issue. I could connect via luci and ssh.
I tried doing the sysupgrade.bin install a couple of times with the same result.
I did veryify the files via a sha256 checksum.
I tried to access the failed sysupgrade.bin via the failsafe method but was not successful (multiple power on and pressing the wps button at various timings). Also tried powering on and pressing the reset button.
I do not yet have a serial cable, though getting one is on an eventual to do list.
I am a complete noob to using non stock fw, though I have been doing quite a bit of reading up. But I don't see why the ...factory.img install works but the ... sysupgrade.bin does not. I assume a bad block issue would affect both installs. I've read a bit about the squashfs and JFFS2 file systems and how the install process works, but again I don't understand why the factory install works but not the sysupgrade. I will admit that I have not yet come across any docs on what is the difference between the two types (factory vs sysupgrade).
The upgrade system is the router conected to a laptop via ethernet cable. Neither the router nor the laptop is connected to the home network / internet. I am not working on a production router, so finding the solution is not asap critical. But I'd greatly appreciate some help figuring out the issue.

factory.img is used the first time you flash OpenWrt. sysupgrade.bin is only used to upgrade from an existing OpenWrt partition, not a Linksys partition.

Both are essentially the same image.

1 Like

Ok, thanks @RuralRoots for straightening me out. I did understand that factory.img was used as a first time change from stock to openwrt, but despite my attempt to be thoughtful and read the how to's and other doc, I had the misconception that sysupgrade.bin still had to be installed after factory.img to somehow finish the process for a first time switch from stock to openwrt. Sigh. I'll go back to the factory.img and start the configuring (and doing more reading up).
Also thanks for not rubbing it in that I am a dunder head. :slightly_smiling_face: (wish there was a homer simpson emoji in the list)


From one Dunder Head to another, welcome to the club :smiley: it’s a big learning curve.

It’s a highly knowledgeable, sharing community here in my estimation - hope you find the same.