Linksys WRT1900ACS no internet on wifi only

I've had my Linksys WRT1900ACS setup with OpenWRT since I had it. The wifi performance is not so good, so I decided to try another fork. I've installed:

Divested-WRT SNAPSHOT r18375+10-54cfe0774c / LuCI Master git-21.343.55550-008bd89

It works nicely on the connection part, but I guess there is some configuration I've missed. My wifi connects, but has no internet connection. I think it goed directly to my modem and I think that does not support that.
I hope you can help me out.
I'm not sure why there is a macaddress configured. The only thing I changed was: enable wifi and put the SSID/password and I want my router to have 1.50 in stead of 1.1.

EDIT: I do have internet on wifi, but certain sites/apps don't work. For example Speedtest. But it doesn't seem to be consistent, some sites do work through LAN but not through WAN. Doesn't make any sense to me.
Changed DNS to 1.1.1.1 now

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:db98:fdc2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.50'

config device
        option name 'wan'
        option macaddr 'c2:56:27:ce:d1:b6'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'