Linksys wrt160nl with openwrt-fw as vpn router behind router 1

Trying to connect a rt WRT160nl behind a main router that does the internet connection. Linksys will be configured later as OpenVPN client serving several DHCP clients in its own vpn network..
I have set up this configuration without problem using DD-WRT and TOMATO routers but am struggling with OPENWRT - the Linksys does not get the internet connection - cable connects main router (LAN port) and Linksys WAN port - this physical connection works fine with DD-WRT and TOMATO.
In the working configurations of the other setups the second router always gets a fixed WAN IP from the main routers pool, asigning it also a fixed IP (very different from the main routers IP subnet) as gateway for its own network - second router asigns IP to its clients in its network by DHCP.

If I could get the Linksys to connect to internet as client of the main router - this would be the first but most important step. How do I have to configure the Linksys WAN, LAN and eventually also the firewall zone?


If the main network is, you will need to change the OpenWrt LAN to something else so there is no conflict. Other than that it should work with a default configuration where OpenWrt gets a WAN IP via DHCP.

1 Like

Main router IP:
Linksys WAN IP (static): (DHCP server in WAN interface disabled) - alternatively setup WAN getting IP from main routers DHCP pool - no change
Linksys LAN IP: (static): (DHCP server in LAN interface enabled)

Linksys is not even shown as "registered" in the main router's network device list (even if I regsiter the Linksys with its MAC adress DIRECTLY in the main router network list) - two other routers with DD-WRT and TOMATO with same configuration show up in the list

does NOT CONNECT to internet

Windows network diagnostic says: "no answer from DNS server" - tried several DNS server IP in WAN interface ( - - - always same result

a) connecting WAN to LINKSYS should just work.
b) assuming the WRT LAN is physically isolated.... and all subnets are /24 then the rest is fairly basic too

please post a screenshot of your firewall or the relevant pieces from /etc/config/firewall

if you changed anything in network... also paste / post. a screenshot /etc/config/network

you really need to be testing from WRT... testing from windows without first verifying / trusting the false "WAN" connection is not very productive.

2 screenshots

Default configuration. Seriously, reset it to default, plug the WAN port into your house LAN (which is, so there's no network conflict), set up a wifi AP on the WRT160 LAN side if you want, and observe that you can reach the Internet through the LAN.

Then feel free to start tinkering until you break it again.

1 Like