Linksys WRT1200AC unstable internet after factory installation

Hello. Recently I installed factory image on my WRT1200AC again and had unstable internet for simingly no reason. Random web pages didn't load at all and few seconds/minutes later they did... This was going on in an endless loop. Default configuration with minor modifications worked fine for me previously for many years. After looking for a solution I found this post and it look promising:

However, attempting that a few times resulted in some networking misconfiguration that forced me to reinstall image, as webgui and ssh were not accessible. Eventually I noticed this line 'uci del network.lan.netmask' before applying changes in webgui:

# /etc/config/dhcp
uci set dhcp.lan.ra_management='1'

# /etc/config/network
uci del network.lan.netmask                                <-- netmask to be removed
uci set network.lan.broadcast='10.10.10.255'
uci set network.lan.gateway='192.198.1.4'
uci add_list network.lan.dns='1.1.1.1'
uci del network.lan.ipaddr
uci add_list network.lan.ipaddr='10.10.10.1'

Looks like not having netmask messed up my config. Adding all config lines manually and rebooting router solved my issue.
Hope this helps someone

Your network is really messed up.

In what way?