Linksys WRT1200AC LAN port getting WAN DHCP IP

I have a Linksys WRT1200AC using LEDE Reboot 17.01.2 r3435-65eec8bd5f / LuCI lede-17.01 branch (git-17.152.82987-7f6fc16)

I have made 4 WAN ports using VLANS (WAN, LAN1, LAN2, LAN3) and only 1 LAN port(LAN4). Everything is working fine when router is online but when I restart router, if I'm using LAN1 or LAN2 or LAN3 port as WAN port PC connected to LAN4 is assigned IP address from WAN DHCP server. If I disconnect LAN4 cable and then I connect it back, the IP address is assigned by the router correctly.

Only happens when restarting router and using LAN1 or LAN2 or LAN3 as WAN port.
Doesn't happen when using WAN port as WAN port.

It seems to me like when restarting there is some time when traffic goes directly to LAN ports without filtering DHCP packets.

Does any one have an idea on how to fix this problem?

On some devices, the hardware switch goes back to a default configuration on boot, before LEDE kicks in and changes it back to your settings. I do not know of any general solution. However, in your particular case, perhaps you could try to use the four LANx ports for WAN, and the WAN port for LAN.

Working fine using WAN as LAN port. haven't tried with multiple WAN lines connected yet, I think should work fine because they all have their own IP.

I hope this can be fixed in a later version. Maybe a script restarting switch once LEDE kicks in could fix it. Not sure.
Where do I have to submit this issue to be fixed or worked around?

Thanks a lot!