Linksys WRT1200AC does not recognize new Arris T25 cable modem

I was running OpenWrt 19.07.2 r10947-65030d81f3 on my Linksys WRT1200AC router connected to an Arris TM722G (133 Mbps, Docsis 3.0) cable modem with voice for xfinity service. In order to upgrade to gigabit service I got a new Arris T25 gigabit cable modem with voice (Docsis 3.1). I disconnected the old cable modem and hooked up the new modem directly to the computer for a temporary internet connection and activated the new modem per xfinity's instruction. So I now had phone service and internet but only on my desktop. I reconnected the computer to the router and the router internet port to the new T25 modem and I lose internet on every device in my apartment. I went back and reactivated to old modem and restored the original set up so I could have internet on all my devices.

With the original set up on the old TM22G modem I see this on the LuCl status page

Under Network it shows the comcast data under ipv4 and ipv6 upstream. But with the new T25 modem under Network it is completely blank. It looks to me as if the wrt1200ac router does not recognize the new T25 modem. Could this be a router hardware problem or firmware (note I have just upgraded the firmware to 19.07.3 and haven't tried the new modem again). Oh I tried all this several times and checked all my connections and cables.

Any assistance or suggestions would be greatly appreciated.



I'd suggest to start with disconnecting old cable modem and router for at least 15 minutes (better half an hour) and only then connecting the new gear. Cable ISPs usually lock onto the router's MAC address and it takes a while for them to release the active lease, if you're lucky this only takes a couple of minutes of everything being disconnected completely, but 15-30 minutes are on the safe(r) side - in the worst case you might have to call your ISP to allow the new modem.

1 Like