LinkSys WRT1200AC 5G Wifi speed 10x higher with dd-wrt based firmware

Howto configure the 5G Wifi on a Linksys WRT1200 AC router to increase speed to 40 Mbyte/s?
Comparing the downloadspeed with an ExpressVPN 2.2.5 firmware, which seems DD-WRT v3.0 based, I can reach up to around 40 Mbyte/s on Channel 149 when downloading a video file from a local server.
The same hardware using openwrt 18.06 can only do 4 Mbyte/s.

Below is the settings used for the openwrt.

cat /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.125.1'
        option gateway '192.168.100.1'
        option dns '192.168.125.6'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option hostname 'router'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option channel '48'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option legacy_rates '1'
        option htmode 'VHT80'
        option country 'CN'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr 'XXXXXX'
        option ssid 'XXXXXX'
        option wmm '0'
        option encryption 'psk2'
        option key 'xxxxxxxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option htmode 'HT20'
        option channel '13'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'CN'
        option legacy_rates '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr 'XXXXX'
        option ssid 'XXXXXX'
        option encryption 'psk2'
        option key 'xxxxxxxx'
        option disabled '1'

iw list

Wiphy phy1
        max # scan SSIDs: 4
        max scan IEs length: 2242 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 1:
                Capabilities: 0x106f
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 4 usec (0x05)
                HT TX/RX MCS rate indexes supported: 0-15, 32
                VHT Capabilities (0x33813930):
                        Max MPDU length: 3895
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        SU Beamformer
                        SU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ AP } <= 16, #{ mesh point } <= 1, #{ managed } <= 1,
                   total <= 16, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2247 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Band 2:
                Capabilities: 0x106f
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 4 usec (0x05)
                HT TX/RX MCS rate indexes supported: 0-15, 32
                VHT Capabilities (0x33813930):
                        Max MPDU length: 3895
                        Supported Channel Width: neither 160 nor 80+80
                        RX LDPC
                        short GI (80 MHz)
                        SU Beamformer
                        SU Beamformee
                        RX antenna pattern consistency
                        TX antenna pattern consistency
                VHT RX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT RX highest supported: 0 Mbps
                VHT TX MCS set:
                        1 streams: MCS 0-9
                        2 streams: MCS 0-9
                        3 streams: not supported
                        4 streams: not supported
                        5 streams: not supported
                        6 streams: not supported
                        7 streams: not supported
                        8 streams: not supported
                VHT TX highest supported: 0 Mbps
                Frequencies:
                        * 5180 MHz [36] (23.0 dBm)
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm)
                        * 5260 MHz [52] (23.0 dBm) (radar detection)
                        * 5280 MHz [56] (23.0 dBm) (radar detection)
                        * 5300 MHz [60] (23.0 dBm) (radar detection)
                        * 5320 MHz [64] (23.0 dBm) (radar detection)
                        * 5500 MHz [100] (disabled)
                        * 5520 MHz [104] (disabled)
                        * 5540 MHz [108] (disabled)
                        * 5560 MHz [112] (disabled)
                        * 5580 MHz [116] (disabled)
                        * 5600 MHz [120] (disabled)
                        * 5620 MHz [124] (disabled)
                        * 5640 MHz [128] (disabled)
                        * 5660 MHz [132] (disabled)
                        * 5680 MHz [136] (disabled)
                        * 5700 MHz [140] (disabled)
                        * 5720 MHz [144] (disabled)
                        * 5745 MHz [149] (30.0 dBm)
                        * 5765 MHz [153] (30.0 dBm)
                        * 5785 MHz [157] (30.0 dBm)
                        * 5805 MHz [161] (30.0 dBm)
        valid interface combinations:
                 * #{ AP } <= 16, #{ mesh point } <= 1, #{ managed } <= 1,
                   total <= 16, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz }

        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing

Turn WMM back on, disabled is an invalid setting for what you desire.

2 Likes

Thanks Ileachi, enabling WMM did it for most of my six routers. They can reach now up to 60MB/s at around 867Mbit/s.
Still I have one router, that will do only 5-10MB/s on the 5G radio0. I compared the output of "cat /etc/config/wireless" with a diff between "good" and "bad" router. All configuration is the same now, the only difference is the MAC, the SSID and the channel number. The "bad" router runs on channel 157, but I also tried other channels like 44, 48, 149. One thing I noticed, is that signal to noise ratio is very bad, actually -5dBm, which means there is more noise than signal, right? Only 30% signal as shown in the LUCI screenshot. Could this indicate a hardware problem? From what I know this would explain, why bitrate is slowed down. How to check where noise comes from or how to improve the SNR?

OpenWrt_router2

A good router has this status with +28 dBm SNR:
OpenWrt_router1

This is the current setting for /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'CN'
        option legacy_rates '1'
        option channel '157'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr 'XXXXX'
        option ssid 'XXXX'
        option encryption 'psk2'
        option key 'XXXXXX'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option disabled '1'
        option country 'CN'
        option legacy_rates '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr 'XXXX'
        option ssid 'XXXX'
        option encryption 'psk2'
        option key 'XXXXX'

You need a:

  • spectrum analyzer
  • a 5.4 GHz power meter with a directional antenna; or
  • simply scan the WiFi and see if there's APs on channel 157

...but I think it's just easier to change the channel...it may be something like the wire inside the antenna is loose.

SNR cannot be a negative number. nonthelss, see here for a more in depth explanation of SNR:

The noise is the same (the noise number has little practical meaning) but the signal is very low on the bad router. -89 is a nearly unusable signal but -59 is a good one. Numbers that are more toward positive infinity are more signal. That is likely a hardware failure if you're testing it with the same client, same channel, same firmware, same location as the other router.

1 Like

I agree with @mk24. If you get the same signal strength, it's likely nothing to worry about.

Thanks, but I don't have that equipment. I tried some other channels, but it seems using 80Mhz bandwidth limits the choice of channels. So if I select 161 it will use 157 instead. Also from the output of "iw list" above I figure that certain channels can't be used in this country due to "radar detection" or they are marked as 'disabled'. Basically on every free channel there is another router present, because we live in a high-story building with 16 apartments next to each other. Can't imagine what the number of routers next to me will be. A high-density urban area (Shanghai). For the moment "auto" seems to be the best choice for this router. (All others work well with fixed channels).

At least sometimes it speeds up to 390 Mbit/s now (right picture) and the SNR in dB is positive.
Thanks for the support.
OpenWrt_router4 OpenWrt_router3

One comment to Ileachi about the SNR, because due to my professional background as electrical engineer I have to comment on this, sorry. The SNR given in dB can very well be negative. Defined as the ratio between signal and noise, the ratio should be greater 1 which results in positive SNR > 0dB, whereas a ratio smaller than 1 will result in negative dB's<0 due to the nature of the logarithm.
SNR
Although you are right, this shouldn't happen. Yet, in radar detection, it is also possible to receive and detect signals although the noise is bigger than the received signal. Since in LUCI/OpenWRT the signal strength was given in dBm, the SNR can be negative (and you are right the same, the SNR ratio (without dB) is never negative).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.