Linksys WHW01 Firmware Build

Hello everyone, I've been trying to build the firmware for the Linksys WHW01 and I'm not having any luck. I've been cloning from this Github:
GitHub - darkarnium/openwrt at Linksys-WHW01v1.
I assume everything is there to be able to compile this myself.

This is what I've been running, I'd like to know what I may be doing wrong.

running Ubuntu 22.04


sudo apt update
sudo apt install build-essential gawk gcc-multilib flex git gettext libncurses5-dev libssl-dev python3-distutils zlib1g-dev

git clone

git branch -a
git checkout LinksysWHW01v1 (im probably doing something wrong in this area)

./scripts/feeds update -a
./scripts/feeds install -a (I've had several make file errors here)

make menuconfig
make (this does not complete due to the errors)

Any help would be appreciated.

Hi, that repository is only tagged up to 19.07.05 - it’s obsolete and no longer supported.

As there are no releases listed it’s possible it never built successfully. You could reach out to the maintainer in case it’s not abandoned?

Alternatively, extract what modifications were done to support the device and bring them up to date with Master.

Found the PR to get this device supported - it was not completed by the developer:

The PR does document all the changes needed to support the device, but only for 19.07, you are going to need to build the DSA support yourself to get to ver 21.

Thanks for the response. So would I still be able to use 19.07.05 even though it's no longer supported? What does DSA stand for, still pretty new to OpenWRT.

THERE you go :slight_smile:

Thanks! :+1:

You could, but if you’re set on staying with v19 start with 19.07.10, the last of the v19 series.

And clone the official openwrt repo rather than an unmaintained fork, then select the 19.07.10 tag and started adding the patches you need from the PR.

okay this is what I tried:

git clone

cd openwrt

git branch -a

git tag

git checkout v19.07.10

scripts/feeds update -a
scripts/feeds install -a


git apply 56efc7f6ebe41aebfb82b6db76df19889c29f120.patch

error: patch failed: package/boot/uboot-envtools/files/ipq40xx:59
error: package/boot/uboot-envtools/files/ipq40xx: patch does not apply
error: patch failed: package/firmware/ipq-wifi/Makefile:42
error: package/firmware/ipq-wifi/Makefile: patch does not apply
warning: target/linux/ipq40xx/base-files/etc/board.d/02_network has type 100755, expected 100644
error: patch failed: target/linux/ipq40xx/base-files/etc/board.d/02_network:67
error: target/linux/ipq40xx/base-files/etc/board.d/02_network: patch does not apply
error: patch failed: target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata:100
error: target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata: patch does not apply
error: patch failed: target/linux/ipq40xx/base-files/etc/init.d/bootcount:10
error: target/linux/ipq40xx/base-files/etc/init.d/bootcount: patch does not apply
error: patch failed: target/linux/ipq40xx/base-files/lib/upgrade/
error: target/linux/ipq40xx/base-files/lib/upgrade/ patch does not apply
error: target/linux/ipq40xx/image/ No such file or directory
error: target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch: No such file or directory

Is there another way to apply a patch or should I apply this a different way.

I wouldn’t expect that to work.

You can either correct all the paths in the patch, and it could still fail, or add the changes from the PR line by line which is more likely to work and will allow you to work around any differences between 19.07.05 and .10 when they arise.

There is no easy or quick way to bring up an unsupported device

I'll go ahead and try both of those options. Hopefully I can get it to work and thanks again for the help.

If anyone else ends up here, someone was able to assist on building the image. Run these and make sure you have installed the prerequisites.

git clone -b Linksys-WHW01v1
cd openwrt
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
make -j $(nproc) kernel_menuconfig
make -j $(nproc) defconfig download clean world

for make menuconfig, the target system is Qualcomm Atheros IPQ40xx, subtarget is Generic and target profile is Linksys WHW01 v1 (feel free to make any other changes you may want)

That should compile successfully assuming you have all needed build dependencies installed, the firmware image you would use to initially flash the WHW01 will be in bin/targets/ipq40xx/generic/openwrt-ipq40xx-generic-linksys_whw01-v1-squashfs-factory.bin

Thanks to sniff122

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.