Linksys RE6500 will not upgrade to 22.03.x

I tried to upgrade my Linksys RE6500 to version 22.03.0 and it gets stuck in a bootloop. I have restored it via the TFTP method found here. I've tried Attended Sysupgrade and a regular upgrade from Luci without saving settings, and each time I attempt to upgrade the bootloop starts again.

It seems this device can't work beyond the 21.02.x release?

Might be the kernel has gotten too big, with the bump to 5.10. To find out what's really going on, you'd really need to hook up serial and check the boot log.

That's what I suspect, but my unit doesn't have any pins on the serial interface. Perhaps I can find someone to solder some on for me. Until then I'll have to keep it on 21.02.x

1 Like

You don have the 3 pins left to heat sink in the first photo?

No, neither one of my RE6500 have any pins, just the empty holes where pins could be soldered.

Wouldn't be the first device with unpopulated serial pins after the FCC crackdown, unfortunately.

Can some one help i have flashed a linksys re6500 and now i can access the setup

You need to start your own thread for your issue.

If in fact the kernel is taking up more space does that mean that 22.03.x has made my device obsolete? If the entire distribution won't fit on the RE6500, what can be done? I remember lots of warnings for 4/32 devices but haven't seen any such warnings for 8gb devices.

Kernel size issues are not necessarily connected to flash size, they can be caused by limitations in either OEM uboot or the device partition layout.

That’s why serial is needed to see what your device is flaking out on. Partition size could be corrected in the dts, though you would not be able to revert to stock easily. If the uboot doesn’t support larger kernels then a uboot rewrite is needed which can be a lot more difficult

1 Like

Hi

I just bricked my RE6500 as well, maybe you should pull back the 22.03 from the device download page. It's really annoying to end up with a bricked device, when the issue is already known?

BR Kasper

The exact cause isn't known since my unit does not have serial pins. We can only guess at the problem until someone can check with a serial connection.

It's fairly easy to use the TFTP method to restore 21.02.x to your device. Here's the link with directions: https://openwrt.org/toh/linksys/re6500#installation

Thanks JC, I already recovered, and yes it is fairly easy, but still frustrating trying to upgrade your firmware and ending with a non-booting device.

/Kasper