Linksys on EA8300, WAN/Internet not working, LAN,WIFI working

Purchased a new Linksys AC2200 EA8300. Installed factory ver 21.02.1, via the Linksys OEM GUI. Install went smooth and Luci even works. Wireless also works. So far so good.
Tried plugging EA8300's WAN port to LAN port on my existing router to test internet connectiity - no joy (by the way I also tried this with the oem software before flashing openwrt and it worked).
Tried plugging EA 8300's WAN port directly to my internet modem (I have a static internet connection) and configuring WAN - also no joy. WAN configuration per below:
Protocol: Static
Device: eth1
IPv4 address: xx.10.14.94
IPv4netmask: 255.255.255.192
IPv4 gateway xx.10.14.65
IPv4 broadcast: I didn't fill out, but I see xx.10.14.127 in background
All other settings were left at default.
my existing router also has DNS1: xx.10.0.2. I added that to the Advanced Settings Tab under "Use Custom DNS servers", but it didn't solve the issue, so I removed it.
Am I missing something or have a wrong setting?

Are you positive that you are supposed to set a static ip? Many providers require the use of dhcp on the customer equipment, even when a static ip is being allocated to the customer. The isp simply uses a dhcp reservation to ensure that the subscriber gets a static ip, but the actual configuration is handled using dhcp. Check your old router configuration or information from the isp.

Other things: you may need to reboot your modem to enable a new device to be connected, or possibly register the new router’s MAC address with the isp. Alternatively, you could try cloning the Mac of the previous router.

1 Like

psherman, thanks for the reply. I live in a rural area; my internet is line-of-sight wireless from the isp tower 7 miles away. I have a flat antenna (1" x 8" x 12") up on my tower, and a small receiver/modem in house where I plug my cat5 into.
Yes, I am positive regarding static. My dd-wrt setup uses the static setting. Internet on the EA8300 does work using oem (Linksys) software, connecting cat5 from EA8300 wan port to a lan port on my old router. That however, I'm assuming that wouldn't solve a mac addr from being blocked by isp. So I'll revert back to oem software (easy todo wince ea8300 holds two flashes) , try with a direct ea8300 to modem connection using oem software, and report back.

Tried mac cloning address from old router to the new router (EA8300). Cloning worked, but still no internet.

As covered in previous post, I don't think the static IP is the issue.

One thing to point out. My MAC address on the box is xx:xx:xx:xx:45:1E.
MAC address on br-lan is same: xx:xx:xx:xx:45:1E
MAC address on eth0 is same: xx:xx:xx:xx:45:1E
but MAC address on eth1 is: xx:xx:xx:xx:45:1F

Is it possible that the EA8300 is just not compatible with openwrt using a static address? Or am I still doing something wrong?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdaa:1145:996d::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'static'
        option device 'eth1'
        option ipaddr 'xx.xx.14.94'
        option netmask '255.255.255.192'
        option gateway 'xx.xx.14.65'
        list dns 'xx.xx.0.2'
        list dns 'xx.xx.0.3'
        list dns '8.8.8.8'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list ra_flags 'none'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
        option name             Support-UDP-Traceroute
        option src              wan
        option dest_port        33434:33689
        option proto            udp
        option family           ipv4
        option target           REJECT
        option enabled          false

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

Have you verified that this is not just a DNS issue?
Try a ping test 8.8.8.8 both from your computer as well as from an ssh session on the router.

Did you test the EA8300 connecting to the ISP (directly) -- and did this work? It is possible that the factory firmware is presenting the 1E address to the ISP. If that is the case, you could try setting the WAN to present the 1F address and the LAN to use 1E.

The MAC address was the culprit. Here are the details. The Linksys box says the MAC address is xx:xx:xx:xx:45:1E. After flashing, and before doing anything except logging into Luci, the LAN had the 1E address; but the ipv4 and ipv6 WAN's both had a 1F address. I thought it odd to have a 1F address, but being new to OpenWrt, I didn't think much of it. I went into Network > Interfaces, Device tab and changed MAC address from 1F to 1E and that solved the problem. Now the LAN and both WAN's have MAC address 1E. Not sure where the 1F address came from? Is it normal for there to be difference MAC address for LAN vs WAN? Should there be different MAC addresses for LAN and WAN?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.