Linksys MR8300 when stable FW?

It will be part of the next (major-) stable release, so 20.xy.0 (or 21.xy.0, as 2020 is almost over), until then you'll only have snapshot support.


The git master branch is reasonably stable fwiw, you might have to deal with the DSA switch stuff however...


Yes is reasonabely stable but i prefer wait the release because eventually problem accour need to solve if something dont work and i don't have the knowledges to do individually. Especially when the only way avaiable is return to original firmware if is possible.

That will occur most likely irregardless of what you're running :wink:

I use EA8300 19.07.4 release instead and very stable. They is nothing wrong trying either EA or MR, as long as you NEVER sysupgrade. This will leave OEM firmware intact and will allow you to failover back to OEM firmware. I have had to go back to OEM on numerous occasions and this has always avoided bricking. I own both EA and MR units.


I didn't understand how I can try OpenWrt without installing it. Can you explain?

There are 2 firmware partitions on most if not all Linksys routers. When you update the firmware, you actually write on the other and then reboot from the other. Everytime you upgrade, your write on the other partition and then reboot from that one. You keep flipping partition at each upgrade. If a particular upgrade goes nuts or is bricked, you can always failover to the previous firmware. The failover procedure is on the EA8300 device page.

So basically the trick here is to boot with latest OEM firmware and installing OpenWrt on the other partition, which then automatically boots from there. OpenWrt is then installed and booting from one partition and the OEM version is on the other, waiting for failover to it. You can then reinstall "factory" OpenWrt from the OEM partition and start all over. It is impossible to brick a device as long as you leave the OEM partition intact in order to failover to known working state. I started my OpenWrt experience with an EA8300, and being a newbee to OpenWrt, I either put myself in trouble or would prefer starting from scratch all over again instead of scratching my head until had no hair left.

The EA and MR are almost identical except for more RAM on MR and very minor radio tuning, the EA OpenWrt firmware runs well on both. Do not OEM upgrade MR with EA OEM as this renders the MR completely dysfunctional on that partition. Thankfully, failover works in that case too.

Hopefully, this clarifies.

Go ahead and experiment OpenWrt all you want, as long as you don't "sysugrade" OpenWrt, as this will overwrite the other partition's OEM firmware and you will be left with both partitions with OpenWrt and the OEM firmware is lost forever and cannot be reinstalled from OpenWrt.

Have fun as these devices are impossible to brick.

1 Like


What I didn't consider is that LinkSys have dual firmware and are actually much more secure than a single firmware. Thanks for the explanation! . So a case of need wanting to re-install the original firmware in both firmware banks is not possible? This could be necessary in case of warranty for hardware problems for example.

You can have both OEM firmware back, just reinstall it from the remaining OEM partition.

BTW, there is an Advanced Reboot luci add-on, that allows to to reboot back to OEM partition without going through the failover/recovery procedure, very strait forward path to OEM, to reinstall whichever firmware you want to boot next.

1 Like

@Bobcat do you know if OpenWrt may be loaded from usb key?

Anyway, i will try when the next release is out. With 512mb of ram i should be okay for some time.

USB support on EA/MR8300 is flackey at best, I would never use USB other than non essential storage.

I think you are confusing 512M ram with the 256 flash. The flash is split in 2 x 128M for main/recovery partitions, OpenWrt has about 70M free for add-on modules. The ram is well... ram...

I mean the total ram available for apk as adblock and other which uses more ram. My old router had 1 core and 128MB and even if it didn't slow down the ram was 80%. SysOp on router only for try obviously.

In the meantime that the release of this router comes out I have installed that of the EA8300 as. Obviously the router is faster than the original firmware but there is a problem. When I apply the settings or download packets or do opkg update from luci, the router stops responding. I checked with the ping -t command and it's confirmed. The compatibility between the MR and the EA is probably not perfect. Do you have any idea what the reason is ?. In the meantime, I put some screenshots then if needed I can put others. Router version 1.1 and something else.


The MR has 512MB of RAM vs 256 in the EA. The radio calibration data for the MR is different than the EA. The LED on top of the MR is different than the EA and needed a different setup.

The issue here is not about ram or led, both of which are known differences and are of no real consequence, furthermore with respect to the radios, I have several MRs running EA release without any issues, and in the early stages of MR support, MR radios running EA release did not cause anything of concern. Up to now, the radio differences are minor tuning parameters, which have basically no demonstrated functionality or runtime issues.

The issue here seems to be a luci plug-in update and nothing else, let's not get lost into non-existent ram, led or radio issues.

However, the recent OEM firmware relates to v.1.1 hardware, maybe this may be introducing issues.

What hardware version do you have ?

Furthermore dnscrypt-proxy is not part of basic functionality, what's your intent here ?

DnsCrypt is one of the plugins I have used in the past on a C7 Archer and it worked without problems and I use it to avoid possible dns search filters. Not really important but more of a curiosity which, however, must work as in other routers if necessary. I have the same problem even without any plugins. In fact I have the same kind of problem when I go to a system, software and "update lists".


If i were to make a guess without evidence but impressions only it could be a read / write problem with the ram. Therefore memory allocation between MR and EA is slightly different perhaps between 1 e 1.1 version?

Maybe I have found the problem (which maybe not a problem). I do some checking and then update.

Well I did a reset and I started from the beginning and the problem of the block did not arise even by reinstalling the ipk that I had installed before. The problem is not completely clear to me but I can assume this:

The router is connected in cascade to another one of the provider in which I have set an ip in DMZ. This IP corresponds to the IP of the second router on the "wan" side and so far everything is normal. The problem is that in order not to remove connectivity to the network I had set the IP of the LAN side to both this MR8300 and an old TP-Link currently in service that will be discontinued. So there were two routers in cascade in parallel with the same WAN side Ip. This probably resulted in packet errors as the datagram contained the same IP used by two different ones. It was enough to set up another IP on the WAN side that works the same even if not in the DMZ to avoid mess with the packets and avoid losing the integrity of the packets and having problems (they are two completely different networks as IP). I have yet to try the Wifi that I see it composed as follows .:
1 radio at 2.4Ghz and 2 radios at 5Ghz, one of which for channels from 36 to 64 and the second radio from 100 to 165. For this latest radio it allows me to have only 20mw of maximum output power visible as in the image. I tried to change the country but nothing changes even leaving "default driver" always 20mW or 13dBm. Am I wrong something? Because 20mW is too low a limit for any country.

Radio 0 is 5GHz @ 30dB 1000mW
Radio 1 is 2.4GHz @ 30dB 1000mW
Radio 2 is 5GHz @ 23dB 199mW, which is lower but max power

All radios run same on my EA or MR routers running EA 19.07.4 release

My EA and MR routers run essentially the same except for more free ram on MR

However, I can say that upon initial setup, many times the max power that can be selected is less than 30dB, a reboot make 30dB selection available afterwards. I've also noticed that disabling then enabling radio also fixes max available output

Maybe you need a reboot if that was not already performed

As a matter of fact, I often reboot my router after an update or change in config which doesn't seem to respond as expected