Linksys MR8300 problem with switch and VLANs

Hi everyone, I just bought a Linksys MR8300 for replacement of my Netgear WNDR3800.
Im configuring it manually, with same Netgear's configs, but in the moment I create the VLANs in the Switch Section, it stops routing my packets.

I mean, Im pinging 8.8.8.8 from my pc, and in the moment i save and apply the changes of the new VLAN those pings stop replying, if i erase the VLAN it starts working again.

I installed OpenWRT 21.02, so i saw the ins a new section in interfaces to add devices, i tried adding devices before adding vlan in switch section but still failing.

Can someone give me a hint about how to setup vlans in mr8300, i saw in the table of hardware's page of mr8300 that switch ports are kinda tricky.

2 Likes

I have an MR8300 as an access point on my network, using VLANs. I did have a bunch of trouble while setting it up, which I think was really that I had the wrong VLAN settings on my ethernet switch (non-tagged egress setting wasn't correct).

What I have now is a trunked connection from the TL-SG108E to the MR8300, using 801.2q VLAN tagging.

I'm running OpenWrt SNAPSHOT r18034-f2f42a54e8 but I think the config is very similar/identical to 21.02.

When I set it up, I was having trouble with VLAN 1 so I switched to a different ID. But that was before I fixed the TL-SG108E config, so it might be irrelevant and VLAN ID 1 might actually work.

network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	option bridge_empty '1'
	list ports 'eth0.4'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option ipv6 '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option hostname 'linksysAP'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'none'
	option auto '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option description 'DONOTUSE'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option description 'WAN'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option description 'IOT'
	option ports '0t 1t 2'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option description 'NEWLAN'
	option ports '0t 1t 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'
	option description 'GUEST'
	option ports '0t 1t'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '4'
	option name 'eth0.4'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '1'
	option name 'eth0.1'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '3'
	option name 'eth0.3'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '5'
	option name 'eth0.5'

config device
	option type 'bridge'
	option name 'br-iot'
	list ports 'eth0.3'
	option bridge_empty '1'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option ipv6 '0'

config interface 'IOT'
	option proto 'dhcp'
	option device 'br-iot'
	option hostname 'linksysAP-IOT'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'eth0.5'
	option bridge_empty '1'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option ipv6 '0'

config interface 'guest'
	option proto 'dhcp'
	option device 'br-guest'
	option hostname 'linksysAP-guest'

2 Likes

thanks for the info, i have being busy these days but i will give it a try with your tips

Thank you very much, now it is working!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.