Linksys MR8300 - crippled mesh connection

I have a Turris Omnia Wifi6 upgraded to tri-band as main router and a handful of Totolink X5000R as 802.11s mesh nodes using 5GHz as wireless backhaul. This setup works great and stable. However, as I wanted to have tri-band on the nodes as well, I got a Linksys MR8300 for testing purposes which gives me plenty of headache. I set it up in the same was as the Totolinks but once connected on the backhaul the network connection of the MR8300 is abysmal: DNS queries fail most of the time, opkg update cannot fetch all package lists, iperf yields about 80kB/s...

This is what I tried w/o success: 22.03.5 & 23.05rc2, using the full-ct-htt packages for both wifi cards and checking both cards (backhaul on QCA9888 for channel 100 or above or IPQ4019 for channel 64 or below). I also applied the recommended changes to the cpufreq governor (up_threshold to 5, sampling_down_factor to 2). Here is the wireless config fusing the QCA9888 (wifi currently disabled)

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '104'
	option band '5g'
	option htmode 'VHT80'
	option country 'DE'
	option cell_density '0'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'mesh'
	option encryption 'sae'
	option key '***'
	option mesh_id 'mesh'
	option mesh_fwding '1'
	option mesh_rssi_threshold '0'
	option disabled '1'

and iwinfo (when wifi was up and running... sort of)

phy0-mesh0 ESSID: "mesh"
          Access Point: EA:9F:80:AF:5A:87
          Mode: Mesh Point  Channel: 104 (5.520 GHz)  HT Mode: VHT80
          Center Channel 1: 106 2: unknown
          Tx-Power: 26 dBm  Link Quality: 40/70
          Signal: -70 dBm  Noise: -103 dBm
          Bit Rate: 385.0 MBit/s
          Encryption: WPA3 SAE (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 168C:0056 0000:0000 [Qualcomm Atheros QCA9886]
          TX power offset: none
          Frequency offset: none

Seeing that many people are successfully using the MR8300 I have surely done something wrong. But what?

I'm in the same case. I tried everything I could last year to put a MR8300 in mesh. Link is done, but bandwidth is a despair. Finally I gave up and setup a WDS link instead (which works great). That won't help you much, but you know you are not the only one to mourn about this.

What a bummer! That was not what I wanted to hear :frowning: Let's see if a success story emerges - otherwise I need to find an alternative tri-band router (w/o breaking the bank).

Well sorry. I have no use of mesh now as it's working with WDS but for I'd like to know the solution anyhow. So if you find it ...

For a general purpose or for a mesh purpose ? For a general purpose this device works like a charm and I would recommand it.


"The Linksys MR8300 is a MU-MIMO Tri-Band WiFi router, which has one 2.4GHz and two 5GHz WiFi Interfaces, making it an interesting choice for wireless backhaul or repeater applications."

That's why I gave it a try.

I'm also using it for the same reason. Each wifi for a purpose, one is used for a bridge to an AP with WDS as I didn't managed to setup a mesh.
PS : I wrote half of this doc :wink:

OK, understood (sort of as -you have noticed that already- I am no network pro). Reading more about WDS sounds interesting. In my case, a mesh is probably a bit overdone. I have a main router and want to have two APs distributed in the house and a third in the garden. Before I moved to OpenWRT I used Asus' AiMesh for that and the garden mesh node used to connect to one of the mesh nodes in the house (not the main router). I guess in case of WDS all clients would have to connect to the main router, right?

As far as I understood yes.
In my case I have only one AP linked to the main router (the MR8300). Easy config.
In your case, you'll have to reconfigure everything ... is it worthy ?

I will give it a go. It seems the router needs no significant config change. And on the AP side I have nothing to lose as the MR8300 does not work right now. If I can't figure it out I can always go back to the working setup with the (dualband) Totolinks.

EDIT: One more question: as the MR8300 acting as AP has a dedicated Wifi card for the backhaul, I guess the mode is STA, as the clients connect to the other Wifi devices of the AP. Correct? I would have to set it to AP if the MR8300 would share the Wifi card with the backhaul to the main router and the network clients (phone. laptop, etc.). Did I get that right?

You need to set the radio on "Access Point WDS", nothing more. Client will still link to it, even without WDS. But this is incompatible with mesh, I mean on the same radio.
On the MR8300 set one radio on "Client WDS". The other radios are to be set as STA as you said.

Many thanks! I will give it a go tomorrow.

1 Like

First setup the MR8300 as a dump AP, than follow the documentation, there are a few settings no to forget.

You need the non-ct drivers for 802.11s mesh.

I'm using the non-ct as default drivers. No result.

Same here - non-ct drivers and the dedicated kmod-ath10k give no significant improvement.

And I have also tried with the ct drivers of course.

I have no mesh network, but I have one MR8300.

Could be something related to encryption (WPA3)?
I had some "problems" with WPA3 and I changed to WPA2 (not in mesh, just normal wifi setup).

1 Like

Agreed. I remember that despite seting an WPA3 password, the device still report "no encryption".

For 802.11s "meshes" which I initially was attempting to set up any mode other than WPA3 is displayed in red with a warning that it is incompatible with 802.11s.

1 Like

Hey, I am recently playing around with MR8300 and trying to setup an 802.11s mesh too. My main router is Linksys E8450 and I am using similar config as yours except that I setup a BATMAN layer on top of the mesh for scalability. When testing with iperf3, I am getting 100+ Kbps from MR8300 node (client) to main router (server) with a lot of retries. But the other way around (main router as client and MR8300 as server) is 100+ Mbps. Do you see iperf throughput the same on both directions?

BTW, I also tried to use AP/STA mode to connect MR8300 to main router. No speed problem there. So the problem is mesh specific. For the mesh, I tried disabling encryption, switching between origin/ct/ct-htt/ct-full-htt firmwares, gpufreq governor, changing mesh in low/high 5G channels (thus different radio), stable/snapshot version of OpenWRT, lowering MTU. But none of them works.

Here are the experiments:
#1 Traffic from MR8300 (OpenWrt-Mesh3, to main router (OpenWrt,

root@OpenWrt-Mesh3:~# iperf3 -c -i 5 -t 20
Connecting to host, port 5201
[  5] local port 48916 connected to port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-5.00   sec   201 KBytes   329 Kbits/sec   45   1.41 KBytes
[  5]   5.00-10.00  sec  62.2 KBytes   102 Kbits/sec   31   2.83 KBytes
[  5]  10.00-15.00  sec  93.3 KBytes   153 Kbits/sec   32   2.83 KBytes
[  5]  15.00-20.00  sec  62.2 KBytes   102 Kbits/sec   26   2.83 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-20.00  sec   419 KBytes   171 Kbits/sec  134             sender
[  5]   0.00-20.00  sec   362 KBytes   148 Kbits/sec                  receiver

iperf Done.

#2 Traffic from main router (OpenWrt, to MR8300 (OpenWrt-Mesh3,

root@OpenWrt:~# iperf3 -c -i 5 -t 20
Connecting to host, port 5201
[  5] local port 59646 connected to port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-5.00   sec  8.11 MBytes  13.6 Mbits/sec    0    209 KBytes
[  5]   5.00-10.00  sec  92.1 MBytes   155 Mbits/sec    0    829 KBytes
[  5]  10.00-15.00  sec   110 MBytes   185 Mbits/sec    0   1.49 MBytes
[  5]  15.00-20.00  sec   115 MBytes   193 Mbits/sec    0   1.49 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-20.00  sec   326 MBytes   137 Mbits/sec    0             sender
[  5]   0.00-20.19  sec   323 MBytes   134 Mbits/sec                  receiver

iperf Done.