Linksys MR8300 can't to work VLAN (IPQ40xx chipset)

Hi,

Any update about the VLAN issue? I have this issue on an MR8300 (it use the EA8300 FW) if I add the VLAN via LUCI, I losing Internet connection.
From the /etc/config/network :

config switch_vlan
        option device 'switch0'
        option vlan '100'
        option ports '0t 2t'

And I configuring the Vlan with :

config interface 'VLAN100'
        option ifname 'eth0.100'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.10.5.1'
        list dns '8.8.8.8'

On the firewall

Still, the computer is on the regular 192 address.

I see there an issue on the about this chipset, (here) Its related do this or I am doing something wrong?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thank you, here the files:

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'HIDDEN'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option ip6assign '60'
        option netmask '255.255.255.224'
        list dns '1.1.1.1'
        list dns '8.8.8.8'
        option ifname 'eth0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        list dns '1.1.1.1'
        list dns '8.8.8.8'
        option peerdns '0'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'
        list dns 'HIDDEN::1111'
        list dns 'HIDDEN::8888'
        option reqprefix 'auto'
        option reqaddress 'try'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3 4'


config switch_vlan
        option device 'switch0'
        option vlan '100'
        option ports '0t 2t'

config interface 'VLAN100'
        option ifname 'eth0.100'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.10.5.1'
        list dns '1.1.1.1'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'PASSWORD'
        option encryption 'psk2'
        option ssid 'WLAN'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'PASSWORD'
        option ssid 'WLAN'
        option encryption 'psk2'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option htmode 'VHT80'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option key 'PASSWORD'
        option ssid 'WLAN'
        option encryption 'psk2'

cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option limit '26'
        option ra_management '1'
        option netmask '255.255.255.240'
        option start '3'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'VLAN100'
        option leasetime '12h'
        option interface 'VLAN100'
        option start '10'
        option limit '15'

cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config include
        option path '/etc/firewall.user'

config zone
        option network 'VLAN100'
        option input 'ACCEPT'
        option forward 'REJECT'
        option name 'VLAN100'
        option output 'ACCEPT'

Is it working now? I wanna buy one MR8300 but i need to use 4 Vlan's.