Linksys EA8500 no serial output

I tried to solder the serial interface on my EA8500 router, after breaking the firmware. But I do not get any output on the serial interface.

Can someone come with some good inputs on what to do?

You may want to make sure that your serial adapter and software are working fine by, for example if you loop it and see if you receive what you send.

Then you should probably check the connection. If you are not confident you may send a photo here for feedback.

I got 2 different converters, and if I connect them together RX <-> TX and TX <-> RX, then I can send messages between both of them in Putty. But when I connect the Linksys EA8500 router, I get no output from the serial interface at all

And can you confirm that the adapter is a 3.3v TTL adapter?

Maybe you should share a photo of the connection?

No problem at all, here is a picture of both the router board, and the TTL adapter.

I could be wrong, but it appears to me that you are connecting the Rx to the Rx and the Tx to the Tx! This is incorrect.

those dongles despite their 3.3v jumper need a voltage divider on their tx line to really be 3.3v...

I tried to switch them around, but still get the same issue. I even tried another tip I found, to connect the serial interface just after the power on. This is to avoid a power surge between the router and the TTL

You could look into what @anon50098793 said.

You may also like to check the quality of your soldering by, for example, check connectivity between the pad on the PCB before the header Text x and the end of the jumper woke using a multimeter.

In all cases, there is very little point of keeping trying swapping Rx and Tx. Make sure you connect the router Tx to the TTL Rx.

I tried to redo my soldering again, and tried to measure on the RX and TX, and it looks like the TX just stay with 3.31 volt on the on PCB. So I don't think it's sending any signal out...

The board is a EWW604-B1-LS REV:305

Any good ideas?

this is expected when working. Hz or a scope would tell you more.

I'm testing another usb serial connected, that I have. On this connector, I can see that when the power on the router is off, there is light in the TX light on the usb serial. But when I turn on the router, the led TX will go off.

So the first part of the picture is with the router on, and then second part is with the router off.

Connect just one line (ground and one signal), and see output initially.

I don't get any output at all... that's the problem that I'm facing. Even when I connect just one line and the ground, I still do not get any output.
I simply don't understand it. I would guess that U-boot should be started, and be writing output to the serial interface. But is that a correct guess?

Yes, if it exists. How have you broken firmware? If you erased u-boot partition, I don't know, what should be.

The last thing I was doing, was to write something to both the linux, and linux2 parititon. When I restarted the router, the router didn't start.
So after this, I added the header to the router, to try to reinstall the firmware, but nothing is showing up on the serial interface.

But are you confident that the soldering is good? You can confirm by checking for connectivity between the last pad before the header (if you can trace it) and the end of the jumper wire.

I can only confirm, that my first serial usb device should be working.
Here is if I use my Pine64, only connecting the GND and the TX from the Pine64 to RX on the serial usb device.