Linksys EA8500 (ipq806x) USB3 fails under load

Running 22.03.5 after a heavy io load the USB3 UASP NVMe drive stops responding.

[15894.673232] sd 1:0:0:0: [sda] tag#5 uas_eh_abort_handler 0 uas-tag 10 inflight: CMD OUT 
[15894.673251] sd 1:0:0:0: [sda] tag#5 CDB: opcode=0x2a 2a 00 77 24 00 58 00 00 08 00
[15899.692923] xhci-hcd xhci-hcd.1.auto: xHCI host not responding to stop endpoint command.
[15899.692975] xhci-hcd xhci-hcd.1.auto: USBSTS: 0x00000000
[15899.732095] xhci-hcd xhci-hcd.1.auto: Host halt failed, -110
[15899.732129] xhci-hcd xhci-hcd.1.auto: xHCI host controller not responding, assume dead
[15899.736902] xhci-hcd xhci-hcd.1.auto: HC died; cleaning up
[15899.745181] usb 4-1: cmd cmplt err -108

When this happens, the device can't even reboot because of the not responding USB device. It needs to physically be power-cycled.

The enclosure is a Sabrent device with the RTL9210B chipset that's known for full UAS support.

I've tried replacing the USB cable, and given the stability under less than heavy io loads, I can rule out any hardware issues.

Any ideas as to how I can troubleshoot this further?

Try an externally powered USB3 hub - the EA8500's USB3 port may not be able to supply sufficient power for the NVMe drive under the heaviest loads.

I forgot to mention, I already tried that as one of my first-line troubleshooting steps after reviewing some of the other threads on here.

Are there any other ideas for troubleshooting this, because the issue is ongoing and is really making this device unusable for my purpose. But not knowing the source of the issue, I'm not sure if switching to a different OpenWRT device would solve the problem, either!

Halp.