Linksys EA8500 esata hard drive not working

#1

Hey folks, have somebody tried to connect esata hdd to EA8500, I have latest snapshot build (also tried 18.06.2) but hdd is not detected, cable and hdd works well on laptop esata port.

[    4.364382] SCSI subsystem initialized
[    4.370056] libata version 3.00 loaded.
[    4.372193] ahci 29000000.sata: AHCI 0001.0300 32 slots 1 ports 6 Gbps 0x0 impl platform mode
[    4.372222] ahci 29000000.sata: flags: ncq sntf pm led clo only pmp pio slum part ccc apst
[    4.380548] scsi host0: ahci
[    4.388474] ata1: DUMMY
0 Likes

#2

Try to install & load those modules:

opkg update
opkg list kmod-\*ata\*
0 Likes

#3

Installed by default:
kmod-ata-ahci
kmod-ata-ahci-platform
kmod-ata-core
Not working

0 Likes

#4

Ok, I found solution and added pull request to EA8500 config, sata port need to be enabled,
more info: https://github.com/openwrt/openwrt/pull/1817

0 Likes

#5

I use EA8500 with OWRT 18.06.2, connect sata ssd drive and it not detected.
(power is ok, eSata cable is ok).

"Ok, I found solution and added pull request to EA8500 config, sata port need to be enabled, more info: https://github.com/openwrt/openwrt/pull/1817"

it's patch for kmod-ata-ahci package ?

0 Likes

#6

No, it's a patch to the DTS, which gets appended to the kernel.

0 Likes

#7

"sata port need to be enabled"

Bug only in 18.06.2 kernel ?

In 18.06.1 kernel sata port enabled ?

=======================================
you wrote about this bug to maintainer,
or to http://lists.infradead.org/pipermail/openwrt-adm/ ?

0 Likes

#8

I think it's valid for all releases, trunk need to be fixed too

1 Like

#9

PR updated to cover all ipq8064 based devices https://github.com/openwrt/openwrt/pull/1821

1 Like

#10

It's nice, but we also need updated 18.06.2 release .

0 Likes

#11

That can only happen after the fix has gone into the master branch, and will be done as a cherry-pick (it should apply without changes) - someone will just have to ask jow or another OpenWrt developer to take it, once it's in (suggesting it in the PR would also be an option). By definition, 18.06.2 can't be fixed anymore, only the upcoming 18.06.3 and 19.02.0.

0 Likes

#12

Why? Next release will get fix, and after merge to master users can use snapshot build, I compiled own one locally with scst (iSCSI target)

0 Likes

#13

Your fix is accepted ?

0 Likes

#14

YEs, merged

0 Likes

#16

Anyone build 18.06.2 for Linksys ea8500 with this fix ?

0 Likes

#17

I think it was merged only to trunk, if you want to have it in 18.06.2 you need to build it

0 Likes

closed #18

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

0 Likes