Linksys EA8300, OpenWRT 22.03.5: not all radios can be active at the same time

Here is my use case: I got a Linksys EA8300 which has 3 WiFi radios: 2 provided by IPQ4019 (radio1=2,4GHz, radio2=5GHz) and one provided by QCA9886 (radio0, 5GHz). The 2 5GHz radios are limited to different channel groups, with radio0 only having access to channels above 100 and radio2 only to channels below 64.

I want to use it as a range extender. I.e. have one of the 5GHz radios connect to another AP as a client, and configure the 2 remaining radios (one 2.4 and one 5GHz) as access points, with routing between the two networks.

I have configured it this way, but I have run into a problem. I cannot enable both 5GHz radios at the same time. Whichever one I configure and enable first stays enabled and functions as intended. The other one can be configured but I cannot enable it. Unless I first disable the first one I enabled, then I can enable the second one.

So I cannot have, for some reason, both radio0 and radio2 enabled at the same time, only one or the other. I have tried OpenWRT 22.03.2 and 22.03.5, the same behavior shows in both builds.

TL;DR version: if I enable radio0 first, I cannot enable radio2; if I enable radio2 first, I cannot enable radio0.

Any ideas why this is, and how I can fix it?
Thanks!

EA8300 v1.1, v22.03.5
I tested with radio 1 (2.4G as the client) connected to a hotspot. Radio 2 comes up (ch 36). Radio 0 didn't work. Set radio 0 from ch 100 (default?) to ch 149. Then it came up. I didn't test connectivity on the AP's though.

Test 2:

  • connect 2 EA8300 ap/sta both v22.03.5
  • router 1: (v1) AP on radio 0 (ch 157) 802.11ac 80Mhz WPA3
  • router 2: (v1.1) client connects successfully on radio 0 (ch 157) and distributes it correctly to radios 1 (ch 1) and 2 (ch 36), and lan ports.

Very interesting; I did not think that the choice of the radio channel has an influence on whether the radio can be enabled or not.

In my specific case, I have to use radio2 for the uplink because the remote AP I'm connecting to is on channel 36 and I can't change that; so I played with essentially all the channels available on radio0 and trying to enable the radio after changing channels. All my attempts failed until I tried the last thing: instead of assigning a specific channel, I set it to "auto". Weirdly enough that allowed me to enable the radio.

Thank you again for your reply, it has led me into the direction that allowed me to solve this problem. I still find this behavior weird, but at least now I have a workaround.

No idea why, as I, too have an EA8300 running 22.03.5, and all three radios are active. One is an uplink (STA), and the other two are APs.

Here is my /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option band '5g'
	option htmode 'VHT80'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'My SSID'
        option encryption 'psk2'
        option key 'My PSK'
        option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel 'auto'
	option band '2g'
	option htmode 'HT40'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'My SSID'
	option encryption 'psk2'
	option key 'My PSK'
	option network 'lan'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option htmode 'VHT80'
	option channel 'auto'
	option cell_density '0'

config wifi-iface 'wifinet2'
	option device 'radio2'
	option mode 'sta'
	option ssid 'My SSID'
	option bssid 'A2:B5:3C:04:E5:AE'
	option encryption 'psk2'
	option key 'My PSK'
	option network 'wwan'

Maybe something in there might be useful.

Mine looks like this (now with both 5GHz radios working:

config wifi-device 'radio0'
         option type 'mac80211'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
         option band '5g'
        option cell_density '0'
         option htmode 'VHT40'
         option channel 'auto'

 config wifi-iface 'default_radio0'
         option device 'radio0'
         option network 'lan'
         option mode 'ap'
         option ssid 'SSID1'
         option encryption 'psk2'
         option key 'somekey'

 config wifi-device 'radio1'
         option type 'mac80211'
         option path 'platform/soc/a000000.wifi'
        option band '2g'
         option htmode 'HT40'
        option channel '10'
         option cell_density '0'

 config wifi-iface 'default_radio1'
         option device 'radio1'
         option network 'lan'
         option mode 'ap'
         option ssid 'SSID2'
         option encryption 'psk2'
         option key 'somekey'

 config wifi-device 'radio2'
         option type 'mac80211'
         option path 'platform/soc/a800000.wifi'
         option channel '36'
         option band '5g'
         option htmode 'VHT80'
        option cell_density '0'

 config wifi-iface 'default_radio2'
         option device 'radio2'
         option network 'lan'
         option mode 'ap'
         option ssid 'OpenWrt'
         option encryption 'none'
         option disabled '1'

 config wifi-iface 'wifinet3'
         option device 'radio2'
         option mode 'sta'
         option network 'wwan'
         option ssid 'xxxxx'
         option encryption 'none'

(yes, I am connecting to an unencrypted AP; so sue me. :slight_smile: it's what's available in my use location)

I'm using a MR8300 in the same scenario than you.

That is the classical DFS issue. On radio0, set channel to auto. It will check for radar and set channel according. If you manually set channel, and that a radar is detected, radio0 will be disabled. This is part of regulations.

You are right to use radio2 (ch36) as link, it's the most powerfull.

I supposed you are using this settings ?

I encourage you to use WDS instead. I have tested both methods and WDs is the easier to configure, the most effective and no routing is involved.

1 Like

I'm actually not using any guides. I'm just assigning the 2 interfaces associated to the 2 APs to the LAN and be done with it. (in this case wlan0 and wlan1, - with wlan2 being the uplink). FWIW I don't want a bridge, I want the AP+their clients to be on a completely different private net.

Also, thank you for explaining why this happens. I am now relieved to know that I'm not just going crazy. :slight_smile:

1 Like

This involves routing, maybe unnecessary. Have you think about a separate bridge, or even vlan ?

I had my part of headache about this before :wink: It's so easy when you know the answer.

I don't mind the routing, after all it is a router :grin: And I do want the downstream network separated from the upstream one, if it makes sense.

It certainly makes sense to desire separate networks according to your need. But you have double routing, double NAT. The EA8300 isn't the main router? Try to spare your devices by rethinking the topology. You can achieve separate networks with several bridges, firewall rules, and if necessary vlans.

One other problem is that I'm kinda running out of IP addresses on the primary network (yes, I do have that many devices :slight_smile: ) and an extra DHCP server on a different subnet won't hurt.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.