Linksys EA8100 v1 - Slow internet connection after a while on both v21.02.3,v22.03.0-rc1

I'm new to OpenWrt and manage to install everything perfectly smoothly on:
Device: Linksys EA8100 v1
Version: v21.02.3,v22.03.0-rc1 <-- i have 2 EA8100 v1 router.

Everything was fine initially and even the internet speed manage to go beyond 310Mbps++ at 5G wifi.
I even manage to setup wireguard server with dynamic dns etc...

however, one thing bugging me is website loading speed will be extremely slow after a while, like 2-3 hours after reboot.
when the slowness happens, i can't ping that website even though it still returns IP address.

at first, I thought it was due to IPV6 (I'm using IPV6 and unable to ping IPV6 when the website is slow).
Then i attempted to disable IPV6 on the entire system.

it only manage to resolve for a while before everything started to repeat again and this time it is on IPV4.

also, i've confirmed that it is not my internet problem as i have routers setup as follow:

  • fiber optic modem (Internet) --> router with default firmware (wifi 1) --> openwrt router (wifi 2).
  • whenever the slowness happen, i'll try to use computer that connect to wifi 1 to check the website and it is extremely fast and able to ping the ip address.

does anyone know how to resolve this? i dont want to keep rebooting the router and the reason i upgrade to openwrt is because of it allow me to setup vpn, dynamic dns etc etc.

Does the problem appear with 'wired' devices?

Have you tried running vanilla openwrt without installing any packages?

1 Like

Thank you for your reply.

I don't have a wired device as the fiber optic point is at the place where I can't place any table for laptop to test.

I have also tried running the vanilla OpenWRT without installing any packages too. i.e.

  • flash the factory firmware, tried the same router for a week and it works perfectly.
  • flash the vanilla OpenWRT.

I spent a few weeks testing these until my family members were all annoyed with the intermitted slowness :frowning:
when the vanilla OpenWRT router works, everything is extremely fast, viewing 4k videos on youtube is almost instant (almost never see the loading icon).

whenever the problem occurs, I'll see the loading icon for almost 2-3minutes before it loads properly, while the other pc where it connects to factory default firmware still works.

I wonder does anyone encounter the same problem as me?

If you are using wireless, your issues may be related to known issues with 7615 as found in EA8100:

1 Like

Thank you for your reply.
it seems like this modem is not supported and will not be fixed.
I bought this modem mainly for OpenWRT and also for 5Ghz wifi.

do you know if there is any problem if i buy Linksys EA7500 v1 instead?
it uses Qualcomm.

fwiw, if you are using 5 GHz wifi on the EA8100 to connect to your main router's wifi, AND to simultaneously to serve 5 GHz wifi to your devices, perhaps that is contributing to the problem by using 'single' radio?

Sorry, I'm not familiar with the EA7500v1. It is powered by IPQ8064 SoC, and uses QCA9982/83 wireless chipsets which may have their own issues. Someone else may be able to answer the question.

imho, the open source wireless drivers provided freely by chip manufacturers for OpenWrt use, are not always as stable as the closed drivers provided to licensed device manufacturers. I personally do not use OpenWrt 'wifi' due to compatibility issues I've encountered myself with both Mediatek and Qualcomm routers.

1 Like

Thank you for your reply.

i'm using only 'single' radio for 5GHz as the WWAN is not supported for 5Ghz. For connection between main router and OpenWRT, i'm using cable.

Thanks for your explanation. I'll try to do some research on the other routers before purchasing next time.

fwiw, have you considered using the EA8100 with stock firmware in 'Access Point' mode to serve wireless? Install a separate 'wired only' openwrt router between the stock-EA8100 and your ISP modem/router.

1 Like

yes, but in other way, i.e.:

  • ISP modem <--> stock firmware (as WiFI AP, static ip on OpenWRT router & w/ port forwarding) <--> OpenWRT (as Wireguard or other services)

the reason I will do it this way is that I only need wireguard whenever I'm out of the country and require me to access my locate network remotely. For the rest of the time, I can pretty much switch off the OpenWRT modem.

I used to configure Raspberry PI for the same purpose but the pi died :frowning:

anyway, will consider your post as a solution! Thank you for your help!

Did you test 22.03.0-rc3 ?

No, I already flash the stable release yesterday and configured everything as per my post earlier.
Spent quite some time configuring everything as I did not back up the config earlier.

I'll try rc3 or future releases next time when I have time. will monitor the thread you mentioned.
Thank you for your reply :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.