Linksys EA7300 v2 Custom build random mac address

Hello,

I use image builder for create a custom image for EA7300, I used a custom network and the original mac addres disappear from ifconfig command and the device show random mac address in wan interface and all others.

I used this file:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'                                                                                                                                                                               
    option ula_prefix 'fd89:1cea:6758::/48'                                                                                                                                                        
    option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'

config device
	option name 'lan2'

config device
	option name 'lan3'

config device
	option name 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.1.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option dns '8.8.8.8'

config interface 'nuup'      
        option proto 'static'
        option ipaddr '10.5.0.1'          
        option netmask '255.255.255.0'
        option delegate '0'               
        list dns '8.8.8.8'            
        list dns '1.1.1.1' 
        list dns '8.8.4.4'

I used OpenWrt 24.10.0, r28427-6df0e3d02a version.

When I used de default openwrt file or the default imagebuider mac address appear ok.

The default network file is:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd06:c59:1a6b::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config device
        option name 'lan1'
        option macaddr 'd8:ec:5e:54:ca:6b'

config device
        option name 'lan2'
        option macaddr 'd8:ec:5e:54:ca:6b'

config device
        option name 'lan3'
        option macaddr 'd8:ec:5e:54:ca:6b'

config device
        option name 'lan4'
        option macaddr 'd8:ec:5e:54:ca:6b'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'd8:ec:5e:54:ca:6b'

The problem is only when I used a custom network file.

What I do wrong?

Thanks a lot for your help

option macaddr 'd8:ec:5e:54:ca:6b'

the one that works have the MACs set hard ... ?

Yes, OpenWrt at build with default network file set the real mac address, but with a custom network file OpenWrt set random mac address, the problem is like Mikrotik RB750Gr3.

In Mikrotik the mac address is stored in a file, but in Linksys I dont know where find them.

Thaks for your help.

Check the EA7300v2 PR at github, see where the MACs are picked up.

I find this:
/etc/board.json

I try tu use this file to get mac address.

Thanks