Linksys EA6350v3 - Unable to use VLAN on WAN port

Hello,
i'm using last OpenWrt 22.03.3 r20028 version (but also previous versione have same problem).
For the FTTH connection i need to use:

  • USERNAME: numero_telefonico
  • PASSWORD: timadsl
  • PROTOCOLLO: PPPoE Routed (definito come RFC 2516)
  • INCAPSULAMENTO: VLAN Ethernet 802.1q
  • NAT: attivo
  • VLAN: 835
  • IGMP proxy: disabilitato
  • Routing: traffico unicast

I try with several configuration withour make it working....
ONT works correctly ( i can ping with 192.168.1.1) and with the router provided by the ISP works correctly.

Don't know how to fix it, i'm desperate.
thanks in advance


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb0:d276:9b64::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr '11:22:33:44:55:9f'

config device
	option name 'eth1'
	option macaddr '11:22:33:44:55:9e'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.1.1.200'

config device
        option name 'fiber'
        option type '8021q'
        option ifname 'eth1'
        option vid '835'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'phonenumber'
	option password 'timadsl'
	option device 'fiber'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config interface 'WANIP'
	option proto 'static'
	option device 'eth1'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.2'

i try also with this config:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb0:d276:9b64::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'eth0'
	option macaddr '..........:9f'

config device
	option name 'eth1'
	option macaddr '.........:9e'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.1.1.200'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 '0'
	option username 'phone number'
	option password 'timadsl'
	option device 'eth1.835'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

I would suggest to take the easy(ier) way out and installing an OpenWrt master snapshot. 22.03.x and earlier was using a very quirky swconfig based driver (which has problems with VLANs) - master has switched to DSA, where that works reliably.