Linksys EA4500 Unable to Sysupgrade

Linksys E4200v2 / EA4500
Current : Firmware Version LEDE Reboot SNAPSHOT r4362-5e4bb476c0 / LuCI Master (git-17.158.76358-75c8eba)
Kernel Version 4.4.71

Everytime I have tried to attempt to sysupgrade this device I am receiving the message "Image metadata not found".
I've been building images for this device since it was added back in the openwrt tree, now I can't figure out exactly what I have done wrong.

I have also attempted to blow it completely away using the sysupgrade -F kirkwood*squashfs.bin, but it displays the same message and locks the router up until I unplug and plug it back in.

It would be a bonus if I could keep my configuration files, but right now it looks like I have a router with some potential security holes. Any help would be appreciated.

What I would try is:

  1. Backup settings
  2. Go back on alternative firmware using the power trick, or install luci-app-advanced-reboot
  3. Reflash from this stock firmware the full *factory.bin
  4. Restore settings
  5. Reinstall packages

If your alternative partition is also running LEDE then I would restore stock firmware first then try that.

Thank you. I have tried TFTP along with the factory firmware with router at 192.168.1.1 / workstation statically set at 192.168.1.10. I cannot get this device to reflash. I do however see kernel version 4.4.70 on the other partition. I have swapped to that partition and am able to boot successfully, but still cannot flash from luci or command line. I appreciate the assistance. I am assuming LEDE is doing additional safety checks it did not before.

Regards

Jean Pierre, thank you again for your help. I managed to flash it from the
older version of lede to 4.9.34. I am still rebuilding packaged, but I am
definitely back on track again.

Glad you got it sorted out! Personnally, I also own an e4200v2 and I always make sure to keep on the alternative partition the original firmware for easy debricking.

So my flash routine is always backup settings, use luci-app-advanced-reboot (before this app I was using the power trick) and do a full factory firmware flash from the stock firmware, wich end up flashing always the same partition. This way I never needed the TFTP recovery mode.

The problem with that is: is my TFTP working at all, that I don't know... ;-). Will try that on my spare time.

Edit: Didn't take too long to test, no TFTP recovery client on this router: https://forum.openwrt.org/viewtopic.php?pid=305301#p305301

Guys I also use an E4200v2 but recently I have run into some worrying issues with backups.

I was debugging something today and I

  • created a backup of my config.
  • Saved that tar file to my computer.
  • Used the reset to factory option in Luci.

Then later I tried a few times to restore my settings from the tar file. It reboots but the settings are never restored.

All the steps above are when running the latest stable Lede.

Model Linksys E4200v2 / EA4500
Firmware Version LEDE Reboot 17.01.2 r3435-65eec8bd5f / LuCI lede-17.01 branch (git-17.152.82987-7f6fc16)
Kernel Version 4.4.71

It is something I noticed before with OpenWRT also.

I've tested tonight with my E4200v2 on LEDE 17.01.1. I've saved my configurations, then issued the firstboot command. The device rebooted and was restored to a factory default indeed.

Then I restored my backup file and I reinstalled the packages (because they are not saved with the configuration, only the settings are saved). Everything was working as expected.

I must admit that I do not use extensively that device and that only nano and luci-app-advanced-reboot are installed on it, so your mileage may vary.

Have you tried with the firstboot to see if your settings could be restored afterward ? Or maybe something was broken with 17.01.2.

I think I may have narrowed it down. It seems that Safari auto-uncompresses the gz file when I do a settings backup. I think sometimes LEDE has an issue then restoring from a tar file.

I have turned off this feature in Safari and will keep an eye on it. Thanks so much for your help DjiPi!

1 Like

Yes I think that you are right. My backups names looks like backup-lede-2017-08-03.tar.gz. If yours are only *.tar that's the problem. Here's another evidence, totally unrelated to LEDE, from another product with similar problems: https://github.com/ccrisan/motioneyeos/issues/190.

@fbradyirl Off-topic: I took my first steps to OpenWrt/LEDE with your build script on ROOter OpenWrt for CandyHouse routers. You kind of introduced me to this community a while ago, thanks!

Oh wow! Cool. You are very welcome!

Have you been keeping an eye on the Qualcom Fastpath thread? I wonder if that would help the E4200v2? Ever tried?

I've indeed keeping an extreme interest on shortcut-fe, not tried anything yet.

I did a build last night with FE kmods but as it was on trunk I was unable to install all the other addons I use so I rolled back to the latest stable.

I've had the same general issue with my EA4500 for both the 17.01.1 and 17.01.2 updates. There's only a sysupgrade.tar provided, should it be a sysupgrade.bin?

For .1 I had to do a 30/30/30 reset to get back to .0 and then do the factory.bin and set things up again (not so hard when you have a backup).

For .2 the sysupgrade to seemed to work but couldn't connect to the WAN. So I again did the factory.bin but this time restored the backup. Seems to have worked nicely.

Seems to be our upgrade procedure needs to be:

  1. backup settings and make a note of additional packages you've installed
  2. flash factory.bin
  3. restore settings
  4. re-install any extra packages you had installed

for the point release updates at least.
EDIT: To add, this is pretty much what DjiPi suggested in the first comment above :wink: