Linksys E8450 not detecting lan cable device after reboot

My routers IP is 192.168.86.1 and my Openmediavault machine having infinite time static IP set in the router is 192.168.86.52. Both are connected via cat6 cable, and so are my other devices.
Whenever I reboot my router, the OMV machine is not detected. What ill have to do is restart the OMV device manually for the router to detect.
This was not the case when I run openwrt on an archer a6 (having the same configurations as main Liksys E8450). The moment both are connected via lan cable, the device gets detected in the DHCP client list. Same with my Google Asus Onhub (no openwrt, just saying this because I tested with this router).
My other device (raspberrypi 4) running OMV (same OMV version on both the device) also works after rebooting the router without issues. All other devices work well.
Also, whenever it connects, it connects only to 192.168.86.52 because I have set this as infinite time static IP.

My router firmware is 22.03. How can this be fixed for the E8450 to detect the lan cable device after reboot?

I hope I have provided enough information to discern this issue. Any kind of help is greatly appreciated.

It's actually up to the device to request a new IP address. This usually happens after the Ethernet carrier is lost and re-detected. The router may not drop the carrier long enough during a reboot to trigger the device to restart its network.

If the device doesn't make a DHCP request, the router will not know that it exists.

The device which I say that is not working is a Core2duo. It is not a SBC. I guess the solution you have is for an arm SBC.

Like I mentioned in the main post. It's works well with archer A6 running openwrt. So the device is making requests like you mention. Only with E8450 running openwrt there's an issue like this.

My dad has an old TP-Link WDR4300, and it showed exactly the same issues with the 22.03.2 release.
From 4 connected lan devices, two would not re-aquire an IP address after router reboot. Had to remove the cable and re-plug it. One of the devices is a Synology NAS, so nothing fancy.

I flashed the latest 21.x OpenWRT just out of curiosity, and the issues is gone!

So please do not tell people that this is an issue of the connected LAN devices.
It seems to be an issue of the latest OpenWRT release!

Also, on my Cudy WR2100 the 22.03.1 Version showed similar behaviour with WLAN devices that simply lost IP addresses (but stayed connected to WLAN!).
In my eyes, there is some real problem deep under the hood with the 22.03 release.

@thmang82 - You appear to be using devices with 2 different targets, so it's hard to know specifically why you're seeing this problem... it doesn't appear to be a common issue, though, or we'd have lots of threads on it. And it is different than the OP.

Are the LAN devices in question directly connected to the router, or is there a switch or other device between the host and the router? Do they report a link but not manage to get an IP, or do they not even see a link?

Can you share the config of one or more of the devices that are experiencing the issue? Maybe there is something wrong in one of those files. If not, logs would be useful, too.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

@psherman - of course, it's 2 targets. The Cudy target has a completely different Mediatek chipset, a platform that still rough to my experience (it's only roughly stable since 22.03.2). The old WDR4300 run on the very old v15 release without any major issues. But it was time for an update, so I took the shot.

Regarding your questions: All 4 LAN devices are directly connected to the router. No switch in between. I cannot give you feedback about link/ip unfortunately. The device is at my parents house, some 500km away, and it will be too difficult to pinpoint it remotly (especially as the router is on the older 21 firmware now).

The config is as follows. It's the current one running v21, but was the same when the v22 release was installed that had the LAN issues:


> cat /etc/config/network

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'

config interface 'lan'
	option force_link '1'
	option proto 'static'
	option ip6assign '60'
	option netmask '255.255.255.0'
	option ipaddr '192.168.11.1'
	option dns '2001:4860:4860::8888 8.8.8.8 8.8.4.4 2001:4860:4860::8844'
	option device 'br-lan'
	option ipv6 '0'

config interface 'wan'
	option proto 'dhcp'
	option ipv6 '1'
	option device 'eth0.2'

config interface 'wan6'
	option proto 'dhcpv6'
	option macaddr 'C4:E9:84:91:xx:xx'
	option reqaddress 'force'
	option reqprefix 'auto'
	option device 'eth0.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1'

config interface 'vpnserver'
	option _orig_ifname 'ovpns0'
	option _orig_bridge 'false'
	option proto 'none'
	option auto '1'
	option device 'ovpns0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'



--------------------
> cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option htmode 'HT40'
	option country 'US'
	option txpower '19'
	option disabled '0'
	option path 'platform/ahb/18100000.wmac'
	option channel '7'
	option legacy_rates '1'
	option cell_density '0'
	option frag '1450'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT40'
	option disabled '0'
	option cell_density '0'
	option country 'DE'
	option distance '30'
	option txpower '17'
	option channel '44'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'xxx_5GHz'
	option key 'xxxxxxxxxxxxxxxxxx'
	option short_preamble '0'
	option disassoc_low_ack '0'
	option dtim_period '1'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2'
	option key 'xxxxxxxxxxxxxxxxxx'
	option ssid 'xxx'
	option network 'lan'

--------------------
> cat /etc/config/dhcp


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'
	option master '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

config host
	option name 'HDHomerunTvTuner'
	option mac '00:18:DD:xx:xx:xx'
	option ip '192.168.11.41'

config host
	option name 'xxxxxxNAS'
	option mac '00:11:32:4E:xx:xx'
	option ip '192.168.11.40'

config host
	option name 'SonyTV'
	option mac 'd8:0f:99:xx:xx:xx'
	option ip '192.168.11.241'

config dhcp 'wan6'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'wan6'
	option dynamicdhcp '0'

--------------------
> cat /etc/config/firewall


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan wlan0'

config zone
	option name 'wan'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option input 'REJECT'
	option network 'wan wan6 WAN6_NEW'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
        option name 'Allow DHCPv6 (546-to-547)' 
	option src 'wan'
	option proto 'udp'
        option src_port '546'
	option dest_port '547'
        option family 'ipv6'
        option target 'ACCEPT' 

config rule
	option name 'Allow-DHCPv6 (547-to-546)'
	option src 'wan'
	option proto 'udp'
	option src_port '547'
	option dest_port '546'
	option family 'ipv6'
        option target 'ACCEPT' 

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config rule
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Allow-OpenVPN-Inbound'
	option src '*'
	option dest_port '1194'
	option proto 'tcp'
	option target 'ACCEPT'

config zone
	option name 'vpnserver'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option network 'vpnserver'
	option masq '1'

config forwarding
	option src 'vpnserver'
	option dest 'wan'

config forwarding
	option src 'vpnserver'
	option dest 'lan'


The HDHomerun tuner stayed connected after reboot, the NAS did not.
Both on LAN, both with static IP assigned.

Another issue:
The SonyTV from the config drops the 5GHz Wifi every 1 to 1.5 hours. As it is used for TV streaming (TvHeadend), my parents are not amused right now :frowning: This was no issue with the very old v15 firmware, but happens on both the 22.x and 21.x release. I played around a bit with the short_preamble, disassoc_low_ack and dtim_period parameters, but no look so far. The TV randomly disconnects and re-connects afterwards after around 30 seconds. It's 4 meter away in the next room in a free standing house, so it's no range/interference issue or something like that. Any idea why this happens with the 21/22 release?

Thanks a lot for checking the config!

Set both radios to the same country. Later firmware uses one instance of hostapd/wpad for both radios and it will have a problem with conflicting settings. Other than country you should not need to add any other options to the wifi-device blocks.

After rebooting check the switch page to see if Ethernet links are reported up. This is the very common AR8237 switch chip still running swconfig so I doubt that anything has changed in the firmware about the switch.

1 Like

Setting both radios to the same country (DE) did not resolve the issue. The TV still dropped the connection and afterwards reconnected from time to time (every hour or s). I tried to downgrade to the latest with the older driver (19). But in that process the router became unresponsive and I am too far away to check what happened. So in the meantime, unfortunately, an old FritzBox must help out.