So I am using an Linksys E7350 currently running OpenWRT 23.05.4. When I try to upgrade to 23.05.5, the router seems to take the update, but when I log in to the router and go to wireless, the devices are showing as generic devices and disabled.
On 23.05.4 the devices (2.4 and 5G bands) are correctly identified (Mediatek MT7621). Uncertain why the wireless driver would have issues on the minor release update, and I cannot seem to find information on why this is occurring.
Any assistance/information is greatly appreciated.
Let’s take a look at the config to make sure there aren’t any issues there.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '0'
option local '/lan-sl/'
option domain 'lan-sl'
option expandhosts '1'
option cachesize '1000'
option readethers '1'
option localservice '1'
option ednspacket_max '1232'
option confdir '/tmp/dnsmasq.d'
list notinterface 'lan'
list notinterface 'lan_main'
list server '<DNS SERVER>'
option port '54'
list interface 'lan_sl'
option sequential_ip '1'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option ignore '1'
option ra 'relay'
option dhcpv6 'relay'
list dhcp_option '6,<DHCP address>'
list dhcp_option '3,<DHCP address>'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'lan_main'
option interface 'lan_main'
option start '100'
option limit '150'
option leasetime '12h'
option ra 'hybrid'
option dhcpv6 'hybrid'
option ignore '1'
list dhcp_option '6,<DHCP address>'
list dhcp_option '3,<DHCP address>'
option ndp 'relay'
option force '1'
config dhcp 'wan6'
option interface 'wan6'
option ignore '1'
option ra 'hybrid'
option dhcpv6 'hybrid'
option ndp 'hybrid'
option master '1'
option ndproxy_routing '0'
config dhcp 'lan_sl'
option interface 'lan_sl'
option start '100'
option limit '150'
option leasetime '12h'
option ra 'hybrid'
option dhcpv6 'hybrid'
option ndp 'hybrid'
option ra_default '2'
list dhcp_option '6,<DHCP address 2>'
list dhcp_option '3,<DHCP address >'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config host
option name 'WAX-220-SL'
option ip '<ip addr>'
option broadcast '1'
list mac '<mac addr>'
config host
option name 'OpenWrt-NUC'
option duid '<DUID>'
option ip '<ip addr>'
option dns '1'
list mac '<mac addr>'
firewall:
config defaults
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
option synflood_protect '1'
config zone
option name 'lan'
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
list network 'lan'
config zone
option name 'lan_main'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'DROP'
list network 'lan_main'
config zone
option name 'wan'
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
option masq '1'
option masq6 '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
config zone
option name 'lan_sl'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan_sl'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
list icmp_type 'bad-header'
list icmp_type 'destination-unreachable'
list icmp_type 'echo-reply'
list icmp_type 'echo-request'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'unknown-header-type'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan_sl'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan_sl'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config forwarding
option src 'lan_sl'
option dest 'wan'
config rule
option name 'WG SL'
list proto 'udp'
option src 'wan'
option dest 'lan_sl'
option target 'ACCEPT'
option dest_port '33462'
config rule
option name 'Support-UDP-Traceroute'
list proto 'udp'
option target 'REJECT'
option src 'wan'
option family 'ipv4'
option dest_port '33434-33689'
option enabled '0'
config redirect
option dest 'lan_sl'
option target 'DNAT'
list proto 'udp'
option src 'wan'
option src_dport '33462'
option dest_port '33462'
option name 'WGSL'
option family 'ipv6'
option dest_ip '<dest_ip_addr>'
config redirect
option dest 'lan_sl'
option target 'DNAT'
option name 'RasPi SSH'
list proto 'tcp'
option src 'wan'
option src_dport '<src_dport>'
option dest_port '<dest_port>'
option dest_ip '<dest_ip_addr>'
As stated in my original email this configuration works on 23.05.4 on the E7350, but the wireless becomes a "generic device" and is not enabled/functioning for 23.05.5.
This configuration is, quite frankly, a mess. There are a lot of things wrong here, and it would take way too long to fix as compared to simply resetting to defaults.
So... reset to defaults and check the WiFi. It should work. Then, configure from scratch to achieve your goals (I have no idea what you were trying to do here since there are so many strange things going on -- if you need help, please describe what those goals are and we can help you realize them).
So, this configuration is a non-standard configuration. I have 2 ISPs (and use mwan3 on my main router) to combine them. This router has one ISP coming in through its WAN, which is connected to its lan (lan_sl). This lan_sl, in turn, is connected via a wireless client WDS connection to an AP that then connects to my main OpenWRT router, running the mwan3.
There are also two other isolated lan interfaces (lan and vlan_lan) which each connect to their own specific port and connect back to the main network through their own WDS client connection.
I have isolated the administration lan from my home network lan, from my secondary (backup) wan (ISP #2).
This router is also running adguardhome for DNS for ISP #2.
As I stated, this configuration works for 23.05.4. It's only when I update the configuration to 23.05.5 that the wireless fails.
When I have some free time, I will try to rebuild the configuration on 23.05.5. I just do not have the time for a few weeks.
Thanks for considering this configuration, in any case. I always appreciate if I can learn something.
One more thing to add - I tried installing a bare 23.05.5 (no configuration, just wipe everything upon uploading the firmware via OpenWRT's System Backup / Flash Firmware), and there is no wireless configuration nor wireless tab on luci upon first boot.
If I ssh into the router, and try "wifi config" to create a base configuration for wireless, it just creates a wireless file that is empty. I think there may be an error in the E7350 OpenWRT version 23.05.5.
Just in case anybody else searches for this topic.
I have the same device at work in my lab. I updated it to 23.05.5 not long ago, but I don't think I've used wifi in the lab since I ran the upgrade, so I don't know off hand if there is any issue. But I'll check tomorrow and let you know.
I just checked -- my lab E7350 is working properly, wifi and all. I am able to see and configure wifi normally, as well as connect to the SSID from a wireless host.
This leads me to believe that your issue is not directly related to 23.05.5 -- it could be a configuration issue or hardware related.
Are you using a default build of 23.05.5, or did you customize it with the image builder?
Thank you for your assistance, Peter. I had a few spare cycles this evening, so I re-flashed the base linksys firmware and then flashed the systemupgrade for 23.05.5 using tftp. It took a few times, for some reason, but it eventually took and boot up into 23.05.5. From there, I just methodically copied files from a backup I had (not just uploading the entire file, but taking it step by step by files to verify that the wireless didn't break again). I'm back up and running and all is good.