Limiting log entries from dnsmasq-dhcp

I seem to be getting quite a few entries in my log which look like this:

Mon Jun  6 14:28:10 2022 daemon.info dnsmasq-dhcp[2660]: DHCPACK(br-lan) 192.168.10.30 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:28:11 2022 daemon.info dnsmasq-dhcp[2660]: DHCPREQUEST(br-lan) 192.168.10.21 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:28:11 2022 daemon.info dnsmasq-dhcp[2660]: DHCPACK(br-lan) 192.168.10.21 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:28:15 2022 daemon.info dnsmasq-dhcp[2660]: DHCPREQUEST(br-lan) 192.168.10.90 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:28:15 2022 daemon.info dnsmasq-dhcp[2660]: DHCPACK(br-lan) 192.168.10.90 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:28:45 2022 daemon.info dnsmasq-dhcp[2660]: DHCPDISCOVER(br-lan) xx:xx:xx:xx:xx:xx
Mon Jun  6 14:28:45 2022 daemon.info dnsmasq-dhcp[2660]: DHCPOFFER(br-lan) 192.168.10.31 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:29:09 2022 daemon.info dnsmasq-dhcp[2660]: DHCPREQUEST(br-lan) 192.168.10.3 xx:xx:xx:xx:xx:xx
Mon Jun  6 14:29:09 2022 daemon.info dnsmasq-dhcp[2660]: DHCPACK(br-lan) 192.168.10.3 xx:xx:xx:xx:xx:xx 
Mon Jun  6 14:29:50 2022 daemon.info dnsmasq-dhcp[2660]: DHCPDISCOVER(br-lan) xx:xx:xx:xx:xx:xx

Regardless of where I set my log level. Right now I have it set to Warning for both System and Cron and it doesn't impact the messages being logged by daemon, but it does handle the kernel messages correctly it seems. Any idea what is going on and how to reduce the logging so that these DHCP messages don't show?

I'm running: OpenWrt 21.02.3 r16554-1d4dea6d4f / LuCI openwrt-21.02 branch git-22.119.37126-a993714, on a Raspberry Pi 4

LuCI->Network->DHCP and DNS->Advanced Settings

image

This will set option quietdhcp '1' in /etc/config/dhcp (in the dnsmasq section).

From the DHCP options:

4 Likes

That was perfect! Thank you!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.