Limited Speed at OpenWrt Access Point

Can you bring one of the merakis directly to your switch and test with a patch cable that is known to support 1Gb/s, or check with another device at the ethernet wallplug usedby the merakis? Maybe the problem is in your wirings. If one of the cables is not correctly wired at the wallplug, then usually you only see 100Mbit/s instead of 1Gbit/s.

You can also try to force the speed. I've seen recentlyq devices that can't negotiate it correctly

ethtool -s <INTERFACE> speed <100|1000|10000> duplex <half|full> autoneg <on|off>

UPDATE:

I forced 1000Mb/s by ethtool as you said:

root@AP2:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

But still no luck...

 Download:  49.43 Mbps
   Upload:  53.90 Mbps
  Latency: [in msec, 61 pings, 0.00% packet loss]
      Min:  17.553
    10pct:  18.046
   Median:  18.961
      Avg:  19.156
    90pct:  20.252
      Max:  23.161
 CPU Load: [in % busy (avg +/- std dev), 58 samples]
     cpu0:  66.1 +/-  4.9
 Overhead: [in % used of total CPU available]
  netperf:  45.3
root@AP2:~#

Semms like ethtool was able to force 1Gb/s connection. Looks like wiring is fine?

I did one more thing. I changed firmware into newest that LuCi let me flash:

Model:
Meraki MR16
Platforma:
ar71xx/generic
Wersja:
19.07.8 (r11364-ef56c85848)
Data:
2021-08-02 00:39:59

No difference at 2.4Ghz but i get around 70 Mb/s on 5Ghz. Netperf directly on AP still gives the same results...

Can’t you flash 21.02?

Force speed…yea but if the hardware works this auto speed negotiation pretty much never fails.

What device do you have in the other end of the cable and what eth speed does that have?

Do you have duplex cat 5e or 6 cables (with cat 5e or 6 connectors if you made the cables themself)?

can you run iperf between router and meraki? or a host in the switch next to the router and meraki ?

Looks like I can't:

Device mr16 not supported by this image Supported devices: meraki,mr16 mr16 - Image version mismatch: image 2.0, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Partitions differ from ar71xx version of MR16. Image format is incompatible. To use sysupgrade, you must change /lib/update/common.sh::get_image to prepend 128K zeroes to this image, and change the bootcmd in u-boot to "bootm 0xbf0a0000". After that, you can use "sysupgrade -F". For more details, see the OpenWrt Wiki: https://openwrt.org/toh/meraki/mr16, or the commit message of the MR16 ath79 port on git.openwrt.org. Invalid image type. Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

HP ProCurve 3500yl-24G-PoE+ J9310A 24-Port Gigabit
eth standard 1000Base -T

I tried cat5e and cat6 cables even cat6 25cm long cable of course ready to use not made by my own.

I suppose I don't know how to use it :slight_smile:

root@AP2:~# iperf -c 192.168.50.1
connect failed: Connection refused
root@AP2:~# iperf -c 192.168.50.8
connect failed: Host is unreachable

192.168.50.1 - main rooter
192.168.50.8 - switch

EDIT:

Looks like real connection speed is still 100Mb/s even when it's forced...

take also @Stefan1 's advice and move the meraki to plug it next to the switch using a short cable that's confirmed to link at 1000mbps

fwiw, what wireless device are you using to measure the speeds?

ie. are you using a phone with single stream wifi, or a laptop with 2x2 stream wifi card?

Ok, thanks. I'll try it later on today.

Network has about 50 clients connected. It was masured on about 10 different devices connected to different Meraki's. Scores are the same.

No changes...

A few things:

  • Check out the console on the 3500yl-24G-PoE to verify that the HP agrees with the state of your links.

  • Upgrade to 21.02, please. There is at least one patch which is critical for good downlink speeds on any newer devices.

  • "Dumb AP" devices (regrettably) still come with a WAN and LAN interface (and a firewall between them); I did see the 192.168.50.1/24 subnet listed above, but the 50-100Mbps limit is pretty close to what the devices can practically handle if they have to pass them through iptables rules. Could you post a (scrubbed) copy of the output of uci export from your devices? I worry that you've switched eth0 to LAN. For more information about how you should configure dumb APs, see here; if you're familiar with https://github.com/gekmihesg/ansible-openwrt, here is your playbook (based on the default configuration of 'eth0' as 'lan':

- hosts: openwrt
  remote_user: root
  tasks:

  - name: Disable dnsmasq
    service:
      name: dnsmasq
      state: stopped
      enabled: no
    register: dnsmasq_state

  - name: Disable odhcpd
    service:
      name: odhcpd
      state: stopped
      enabled: no

  - name: Reload network if dnsmasq was disabled
    when: dnsmasq_state.changed
    service:
      name: network
      state: reloaded

  - name: Disable firewall
    service:
      name: firewall
      state: stopped
      enabled: no
2 Likes

Given the CPU load:

 CPU Load: [in % busy (avg +/- std dev), 58 samples]
     cpu0:  88.4 +/-  9.1

... you are almost certainly passing packets through the firewall (verify with iptables -L -n -x -v and watch netperf as counts go up).

You need to

1a) Link eth0 and wlan0 and wlan1 (default examples) in /etc/config/network to interface lan (br-lan)
1b) Set the device as a dhcp client /etc/config/network (interface lan ... option proto 'dhcp');
2) Disable your firewall (/etc/init.d/firewall disable; /etc/init.d/dnsmasq stop;)
3) Disable dhcp server (/etc/init.d/dnsmasq disable; /etc/init.d/dnsmasq stop;)
4) Reboot to ensure that /etc/resolv.conf gets properly symlinked so the device itself can do DNS (but not serve it, dnsmasq is disabled!)

See, again, https://openwrt.org/docs/guide-user/network/wifi/dumbap.

2 Likes

As @hurricos has suggested, are your MR16s are running as routers, or reconfigured as dumb APs ?

1 Like

If my scrubbed version is not scrubbed enough please point on sensitive parts so I could know for the future :smiley:

Access Point:

root@AP5:~# uci export
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package dropbear

config dropbear
        option PasswordAuth 'on'
        option RootPasswordAuth 'on'
        option Port '22'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

package luci

config core 'main'
        option lang 'auto'
        option mediaurlbase '/luci-static/bootstrap'
        option resourcebase '/luci-static/resources'
        option ubuspath '/ubus/'

config extern 'flash_keep'
        option uci '/etc/config/'
        option dropbear '/etc/dropbear/'
        option openvpn '/etc/openvpn/'
        option passwd '/etc/passwd'
        option opkg '/etc/opkg.conf'
        option firewall '/etc/firewall.user'
        option uploads '/lib/uci/upload/'

config internal 'languages'

config internal 'sauth'
        option sessionpath '/tmp/luci-sessions'
        option sessiontime '3600'

config internal 'ccache'
        option enable '1'

config internal 'themes'
        option Bootstrap '/luci-static/bootstrap'

config internal 'apply'
        option rollback '90'
        option holdoff '4'
        option timeout '5'
        option display '1.5'

config internal 'diag'
        option dns 'openwrt.org'
        option ping 'openwrt.org'
        option route 'openwrt.org'

package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '*************'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'dhcp'

package rpcd

config rpcd
        option socket '/var/run/ubus.sock'
        option timeout '30'

config login
        option username 'root'
        option password '*******'
        list read '*'
        list write '*'

package system

config system
        option ttylogin '0'
        option log_size '64'
        option urandom_seed '0'
        option zonename 'UTC'
        option hostname 'AP5'
        option log_proto 'udp'
        option conloglevel '8'
        option cronloglevel '5'

config timeserver 'ntp'
        list server '0.openwrt.pool.ntp.org'
        list server '1.openwrt.pool.ntp.org'
        list server '2.openwrt.pool.ntp.org'
        list server '3.openwrt.pool.ntp.org'

config led 'led_wan'
        option name 'WAN'
        option sysfs 'mr16:green:wan'
        option trigger 'netdev'
        option mode 'link tx rx'
        option dev 'eth0'

config led 'led_wlan1'
        option name 'WLAN1'
        option sysfs 'mr16:green:wifi1'
        option trigger 'phy0assoc'

config led 'led_wlan2'
        option name 'WLAN2'
        option sysfs 'mr16:green:wifi2'
        option trigger 'phy0assoc'

config led 'led_wlan3'
        option name 'WLAN3'
        option sysfs 'mr16:green:wifi3'
        option trigger 'phy0assoc'

config led 'led_wlan4'
        option name 'WLAN4'
        option sysfs 'mr16:green:wifi4'
        option trigger 'phy0tpt'

package ubootenv

package ucitrack

config network
        option init 'network'
        list affects 'dhcp'
        list affects 'radvd'

config wireless
        list affects 'network'

config firewall
        option init 'firewall'
        list affects 'luci-splash'
        list affects 'qos'
        list affects 'miniupnpd'

config olsr
        option init 'olsrd'

config dhcp
        option init 'dnsmasq'
        list affects 'odhcpd'

config odhcpd
        option init 'odhcpd'

config dropbear
        option init 'dropbear'

config httpd
        option init 'httpd'

config fstab
        option exec '/sbin/block mount'

config qos
        option init 'qos'

config system
        option init 'led'
        option exec '/etc/init.d/log reload'
        list affects 'luci_statistics'
        list affects 'dhcp'

config luci_splash
        option init 'luci_splash'

config upnpd
        option init 'miniupnpd'

config ntpclient
        option init 'ntpclient'

config samba
        option init 'samba'

config tinyproxy
        option init 'tinyproxy'

package uhttpd

config uhttpd 'main'
        list listen_http '0.0.0.0:80'
        list listen_http '[::]:80'
        list listen_https '0.0.0.0:443'
        list listen_https '[::]:443'
        option redirect_https '1'
        option home '/www'
        option rfc1918_filter '1'
        option max_requests '3'
        option max_connections '100'
        option cert '/etc/uhttpd.crt'
        option key '/etc/uhttpd.key'
        option cgi_prefix '/cgi-bin'
        list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
        option script_timeout '60'
        option network_timeout '30'
        option http_keepalive '20'
        option tcp_keepalive '1'

config cert 'defaults'
        option days '730'
        option key_type 'rsa'
        option bits '2048'
        option ec_curve 'P-256'
        option country 'ZZ'
        option state 'Somewhere'
        option location 'Unknown'
        option commonname 'OpenWrt'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:11.0'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key '************'
        option ssid 'TST'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:12.0'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key '*****************'
        option ssid 'TST5g'
        option encryption 'psk2'

Main Router:

root@Router_Bukowa:~# uci export
package collectd

config globals 'globals'
        option alt_config_file '/etc/collectd.conf'

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option start '1'
        option limit '254'
        option force '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
(***)

package dropbear

config dropbear
        option PasswordAuth 'on'
        option RootPasswordAuth 'on'
        option Port '22'

package etherwake

config etherwake 'setup'
        option pathes '/usr/bin/etherwake /usr/bin/ether-wake'
        option sudo 'off'
        option broadcast 'off'

config target
        option name 'example'
        option mac '11:22:33:44:55:66'
        option password 'AABBCCDDEEFF'
        option wakeonboot 'off'

package firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option flow_offloading '1'
        option flow_offloading_hw '1'
        option synflood_protect '1'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'home'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'

config forwarding
        option src 'home'
        option dest 'wan'

config forwarding
        option src 'home'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'home'

config zone
        option name 'TST2'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option network 'TST2'
        option masq '1'

config forwarding
        option src 'TST2'
        option dest 'wan'

config forwarding
        option src 'TST2'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'TST2'

package luci

config core 'main'
        option lang 'auto'
        option mediaurlbase '/luci-static/bootstrap'
        option resourcebase '/luci-static/resources'
        option ubuspath '/ubus/'

config extern 'flash_keep'
        option uci '/etc/config/'
        option dropbear '/etc/dropbear/'
        option openvpn '/etc/openvpn/'
        option passwd '/etc/passwd'
        option opkg '/etc/opkg.conf'
        option firewall '/etc/firewall.user'
        option uploads '/lib/uci/upload/'

config internal 'languages'

config internal 'sauth'
        option sessionpath '/tmp/luci-sessions'
        option sessiontime '3600'

config internal 'ccache'
        option enable '1'

config internal 'themes'
        option Bootstrap '/luci-static/bootstrap'

config internal 'apply'
        option rollback '90'
        option holdoff '4'
        option timeout '5'
        option display '1.5'

config internal 'diag'
        option dns 'openwrt.org'
        option ping 'openwrt.org'
        option route 'openwrt.org'

package luci_statistics

config statistics 'collectd'
        option BaseDir '/var/run/collectd'
        option Include '/etc/collectd/conf.d'
        option PIDFile '/var/run/collectd.pid'
        option PluginDir '/usr/lib/collectd'
        option TypesDB '/usr/share/collectd/types.db'
        option Interval '30'
        option ReadThreads '2'

config statistics 'rrdtool'
        option default_timespan '1hour'
        option image_width '600'
        option image_path '/tmp/rrdimg'

config statistics 'collectd_rrdtool'
        option enable '1'
        option DataDir '/tmp/rrd'
        option RRARows '144'
        option RRASingle '1'
        option RRATimespans '1hour 1day 1week 1month 1year'

config statistics 'collectd_csv'
        option enable '0'
        option StoreRates '0'
        option DataDir '/tmp'

config statistics 'collectd_email'
        option enable '0'
        option SocketFile '/var/run/collectd/email.sock'
        option SocketGroup 'nogroup'

config statistics 'collectd_logfile'
        option enable '0'
        option LogLevel 'notice'
        option File '/var/log/collectd.log'
        option Timestamp '1'

config statistics 'collectd_network'
        option enable '0'

config statistics 'collectd_unixsock'
        option enable '0'
        option SocketFile '/var/run/collectd/query.sock'
        option SocketGroup 'nogroup'

config statistics 'collectd_apcups'
        option enable '0'
        option Host 'localhost'
        option Port '3551'

config statistics 'collectd_conntrack'
        option enable '0'

config statistics 'collectd_contextswitch'
        option enable '0'

config statistics 'collectd_cpu'
        option enable '1'
        option ReportByCpu '1'
        option ReportByState '1'
        option ValuesPercentage '1'

config statistics 'collectd_cpufreq'
        option enable '0'

config statistics 'collectd_curl'
        option enable '0'

config statistics 'collectd_df'
        option enable '0'
        option Devices '/dev/mtdblock/4'
        option MountPoints '/overlay'
        option FSTypes 'tmpfs'
        option IgnoreSelected '0'

config statistics 'collectd_disk'
        option enable '0'
        option Disks 'hda1 hdb'
        option IgnoreSelected '0'

config statistics 'collectd_dns'
        option enable '0'
        option Interfaces 'br-lan'
        option IgnoreSources '127.0.0.1'

config statistics 'collectd_entropy'
        option enable '0'

config statistics 'collectd_exec'
        option enable '0'

config statistics 'collectd_interface'
        option enable '1'
        option Interfaces 'br-lan'
        option IgnoreSelected '0'

config statistics 'collectd_iptables'
        option enable '0'

config collectd_iptables_match
        option table 'nat'
        option chain 'luci_fw_postrouting'
        option target 'MASQUERADE'
        option source '192.168.1.0/24'
        option outputif 'br-ff'
        option name 'LAN-Clients traffic'

config collectd_iptables_match
        option chain 'luci_fw_postrouting'
        option table 'nat'
        option target 'MASQUERADE'
        option source '10.61.230.0/24'
        option outputif 'br-ff'
        option name 'WLAN-Clients traffic'

config statistics 'collectd_irq'
        option enable '0'
        option Irqs '2 3 4 7'

config statistics 'collectd_iwinfo'
        option enable '1'

config statistics 'collectd_load'
        option enable '1'

config statistics 'collectd_memory'
        option enable '1'
        option ValuesAbsolute '1'
        option ValuesPercentage '0'

config statistics 'collectd_netlink'
        option enable '0'
        option IgnoreSelected '0'
        option VerboseInterfaces 'br-lan'
        option QDiscs 'br-lan'

config statistics 'collectd_nut'
        option enable '0'
        list UPS 'myupsname'

config statistics 'collectd_olsrd'
        option enable '0'
        option Port '2006'
        option Host '127.0.0.1'

config statistics 'collectd_openvpn'
        option enable '0'

config statistics 'collectd_ping'
        option enable '0'

config statistics 'collectd_processes'
        option enable '0'
        option Processes 'uhttpd dnsmasq dropbear'

config statistics 'collectd_sensors'
        option enable '0'

config statistics 'collectd_splash_leases'
        option enable '0'

config statistics 'collectd_tcpconns'
        option enable '0'
        option ListeningPorts '0'
        option LocalPorts '22 80'

config statistics 'collectd_thermal'
        option enable '0'
        option IgnoreSelected '0'

config statistics 'collectd_uptime'
        option enable '0'

package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '************'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.50.1'
        option igmp_snooping '1'
        option stp '1'
        option ifname 'eth1 eth2 eth3 eth4 eth5 zt_TST2'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

config interface 'TST2'
        option ifname 'zt_TST2'
        option proto 'none'

package rpcd

config rpcd
        option socket '/var/run/ubus.sock'
        option timeout '30'

config login
        option username 'root'
        option password '*******'
        list read '*'
        list write '*'

package sqm

config queue 'eth1'
        option qdisc_advanced '0'
        option linklayer 'none'
        option interface 'eth0'
        option download '700000'
        option upload '700000'
        option debug_logging '0'
        option verbosity '5'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option enabled '0'

config queue
        option debug_logging '0'
        option verbosity '5'
        option qdisc 'fq_codel'
        option script 'simple.qos'
        option linklayer 'none'
        option interface 'eth1'
        option download '700000'
        option upload '700000'
        option qdisc_advanced '0'
        option enabled '0'

package system

config system
        option ttylogin '0'
        option log_size '64'
        option urandom_seed '0'
        option zonename 'Europe/Warsaw'
        option hostname 'Router_Bukowa'
        option log_proto 'udp'
        option conloglevel '8'
        option cronloglevel '5'
        option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'

config timeserver 'ntp'
        list server '0.openwrt.pool.ntp.org'
        list server '1.openwrt.pool.ntp.org'
        list server '2.openwrt.pool.ntp.org'
        list server '3.openwrt.pool.ntp.org'

package ucitrack

config network
        option init 'network'
        list affects 'dhcp'
        list affects 'radvd'

config wireless
        list affects 'network'

config firewall
        option init 'firewall'
        list affects 'luci-splash'
        list affects 'qos'
        list affects 'miniupnpd'
        list affects 'sqm'

config olsr
        option init 'olsrd'

config dhcp
        option init 'dnsmasq'
        list affects 'odhcpd'

config odhcpd
        option init 'odhcpd'

config dropbear
        option init 'dropbear'

config httpd
        option init 'httpd'

config fstab
        option exec '/sbin/block mount'

config qos
        option init 'qos'

config system
        option init 'led'
        option exec '/etc/init.d/log reload'
        list affects 'luci_statistics'
        list affects 'dhcp'

config luci_splash
        option init 'luci_splash'

config upnpd
        option init 'miniupnpd'

config ntpclient
        option init 'ntpclient'

config samba
        option init 'samba'

config tinyproxy
        option init 'tinyproxy'

config luci_statistics
        option init 'luci_statistics'

config sqm
        option init 'sqm'

package uhttpd

config uhttpd 'main'
        list listen_http '0.0.0.0:80'
        list listen_http '[::]:80'
        list listen_https '0.0.0.0:443'
        list listen_https '[::]:443'
        option redirect_https '1'
        option home '/www'
        option rfc1918_filter '1'
        option max_requests '3'
        option max_connections '100'
        option cert '/etc/uhttpd.crt'
        option key '/etc/uhttpd.key'
        option cgi_prefix '/cgi-bin'
        list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
        option script_timeout '60'
        option network_timeout '30'
        option http_keepalive '20'
        option tcp_keepalive '1'

config cert 'defaults'
        option days '730'
        option key_type 'rsa'
        option bits '2048'
        option ec_curve 'P-256'
        option country 'ZZ'
        option state 'Somewhere'
        option location 'Unknown'
        option commonname 'OpenWrt'

package zerotier

config zerotier 'sample_config'
        option enabled '0'
        list join '*******'

config zerotier 'TST2'
        list join '************'
        option enabled '1'
        option secret '*************'

I will be able to flash device tomorrow probably. I will write if it helped.

On auto mode Switch finds AP as 100Mb/s device. I set 1000base-T manually but it didn't change anything. I tried to connect directly to router but still no difference. As I suppose it's not about the switch. Probably I messed out something in config. I hope you'll find it :slight_smile:

Was suppose to run as Dumb AP. Please take a look to config to see if i did it right...