Libre H3-CC H5 issues

I have tried tio load: openwrt-22.03.5-sunxi-cortexa53-libretech_all-h3-cc-h5-ext4-sdcard and openwrt-23.05.0-rc2-sunxi-cortexa53-libretech_all-h3-cc-h5-ext4-sdcard onto this board - image boots but cannot get past the
"Please press enter to activate this console." - The keyboard is never initialized. The keyboard is fine as I have installed ubuntu and raspian on this board and everything works fine. I have also tried to boot with only an ethernet and no mouse - does not help - the initial messages see one usb device - the keyboard - any help will be greatly appreciated - thanks in advance

Just to be sure: Have you tried to attach another device via LAN and to connect to (either via a Browser, then you should see LuCI, or via SSH)? OpenWrt does not boot into any GUI, it will stay on a command line.

Additionally, given that sunxi is very actively maintained mainline and as your device uses removable media, please also give 23.05.0-rc2 a try. While I have no idea if that helps (don't have any sunxi devices myself), it is an easy test to see if further debugging is even needed (if 23.05~ is fixed, just stick with it - if it isn't, you'll have to dig in deeper).

I have the board attached via ethernet to my home network which is on - if I try to ssh into - it times out. I am not expecting a gui - for some reason it does not see the keyboard - I can hit a key at the "hit any key to stop autoboot and I can stop the boot - if I type help, I get a long list of commands. If I type boot, it finishes the kernel load and I get the prompt after the 4 penguins - at this point there is no response from the keyboard.
To SLH - I have tried 23.05.0-rc2 - same result

I have tried 23.05.0-rc2 - what I am now running - same result