Libpcre no depend

I'm trying to compile and I get

"WARNING: Makefile 'package/feeds/telephony/freeswitch/Makefile' has a dependency on 'libpcre', which does not exist"

I'm running Debian on a Pi

Thankz
Jeff

how is this openwrt related ?

He's seeing it while building OpenWrt (as are most of us using main):

$ make -j32 world
Collecting package info: done
WARNING: Makefile 'package/feeds/telephony/freeswitch/Makefile' has a dependency on 'libpcre', which does not exist
#
# No change to .config
#
...

I just ignore it as I don't use freeswitch, and it doesn't affect me.

1 Like

Please test proposed patch and add a positive review if successful.

1 Like

I have it too, libpcre is deprecated not sure if freeswitch will work with libpcre2.

I use this patch to stop that messages:

diff --git a/net/freeswitch/Makefile b/net/freeswitch/Makefile
index 213e45b..590e264 100644
--- a/net/freeswitch/Makefile
+++ b/net/freeswitch/Makefile
@@ -320,7 +320,7 @@ $(call Package/freeswitch/Default)
 	  +libcurl \
 	  +libedit \
 	  +libopenssl \
-	  +libpcre \
+	  +libpcre2 \
 	  +libpthread \
 	  +librt \
 	  +libspandsp3 \

I checked we are using the latest freeswitch but I did not research further not using any telephony

Thanks did not catch that :slight_smile:

Thankz
Have A Great Day