Let'sEncrypt, ACME.sh and LUCI App Acme support topic

Luci uses uhttpd instead

--log [file] Specifies the log file. Defaults to "/root/.acme.sh/acme.sh.log" if argument is omitted.

Is it there perhaps?

I'm also having problem and I tried the fix mentioned before and none worked .. checking the debug I could see this wrong path "yes/.well-known" maybe the cause of my problem:

_currentRoot='yes'
wellknown_path='yes/.well-known/acme-challenge'
writing token:--REDACTED-- to yes/.well-known/acme-challenge/--REDACTED--

I checked the content of the above message is located inside the client.sh file, but it has over 8k lines .. and my knowleged isn't that big to find how to fix the directory

EDIT: I fixed just doing this:
ln -s /var/run/acme/challenge/yes/.well-known/acme-challenge/ /www/.well-known/acme-challenge

the problem is here, for some reason the yes is used in a path. Please check configuration

In case anyone else runs into this, on one of my systems it was caused by /usr/lib/acme/hook being updated for key_type but /etc/init.d/acme not being updated. I guess maybe a dependency between acme.sh and acme-common is wrong? I'm not that familiar with opkg.

Anyway, check out https://github.com/openwrt/packages/commit/66894032d482625a1a7e22ba4336c6fa5dd35d26 and apply the second diff's changes to /etc/init.d/acme and it should work.