LEDE - WRT3200ACM - Upstream not detection DHCP

I recently applied the lede-mvebu-linksys-wrt3200acm-squashfs-factory.img to my Linksys WRT3200ACM. The installation went fine but I'm having a problem. I want a basic system where my upstream connection uses dhcp to obtain an IP and when a client to connect to wireless (2,4G ), they have access via the upstream to the internet. I've tried several options and reviews the DHCP and Networking configurations but I'm not having much success. I would appreciate any advice or help.

/etc/config/network contains:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd1c:32ef:b6d0::/48'

config interface 'lan'
option ifname 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.1.1'

config interface 'eth0'
option ifname 'eth0'
option proto 'dhcp'

config interface 'wan'
option ifname 'wan'
option proto 'dhcp'

config interface 'wan6'
option ifname 'wan'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6'


/etc/config/dhcp contains

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'


ifconfig shows that eth0 is not obtaining an IP address:

eth0 Link encap:Ethernet HWaddr 62:38:E0:B5:8B:D8
inet6 addr: fe80::6038:e0ff:feb5:8bd8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:217 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:0 (0.0 B) TX bytes:71795 (70.1 KiB)
Interrupt:35

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:496 errors:0 dropped:0 overruns:0 frame:0
TX packets:496 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:32240 (31.4 KiB) TX bytes:32240 (31.4 KiB)

wlan0 Link encap:Ethernet HWaddr 60:38:E0:B5:8B:DA
inet6 addr: fe80::6238:e0ff:feb5:8bda/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:864 (864.0 B)

wlan1 Link encap:Ethernet HWaddr 60:38:E0:B5:8B:D9
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

I didn't have much time to toy around with it, but I had a similar problem (not getting IP from dhcp server on wan port) with 17.01 snapshot r3042 on wrt3200.

Yea, I've tried a lot of different combinations but not having much success. The only think that works is to create a static IP which defeats the purpose of DHCP. If you discover a solution, I'd love to hear about it. I'm at the point of being stuck :wink:

Sorry, not much time to mess around with WRT3200ACM at the moment and I'm quite happy with EA8500 until then.

PS. Not sure if you know -- assigning LEDs to WiFi kills WiFi.

What is your connection to ISP? Cable, DSL, ethernet/FO?

The most frustrating part of my experience was that swconfig wouldn't even show port 4 link as up. So I ended up calling my ISP (they provide direct ethernet connections in my building) and they've switched equipment on their side of auto-negotiation to force 100full. That helped, my router picked up the connection and started working.

I'm guessing that if static DHCP works for you by dynamic doesn't you might have a different issue.

I've resolved this issue. After installing LEDE - take a look at this http://www.jauu.net/2015/03/03/complete-openwrt-guide/ to resolve an issue I found with DHCP not being resolved. This was helpful in understanding that eth0 is for the local network - eth1 is for the uplink and the wireless is basically an extension of the LAN.

So what was the issue? You overwrote the default LEDE network config with something else and it borked your network?

The default LEDE network config for WRT3200ACM has been working just fine for me, no need to change anything.

Take a look to this tutorial for lede to improve wifi speed after lede installation