Lede v17.01.0 freeze network communication (Wireless Routed Client)

Hi,

i've just installed latest Lede-Project build, version 17.01.0-r3205-59508e3, on a Nucom 5010UN V2 router and everything seemed to work fine until i noticed that it keeps loosing Internet/network connection. The router is configured as Wireless Routed Client and the firmware was downloaded from https://downloads.lede-project.org/releases/17.01.0/targets/brcm63xx/generic/lede-17.01.0-r3205-59508e3-brcm63xx-generic-R5010UNv2-squashfs-cfe.bin

Also note, i think it's a common bug inherited from OpenWrt as i suffered the same exact bug on an ADB P.DG A4001N1 router running latest build of OpenWrt, Chaos Calmer 15.05 and also 15.05.1. Also note that after posting on OpenWrt forums more users complained about the same bug.

Also, i want to state that in OpenWrt, the issue can be workarounded by downgrading to Barrier Breaker 14.07 which means the bug was introduced on the next build or next commits.

Anyway, my current setup is on Nucom 5010UN v2 is Wireless Routed Client [https://wiki.openwrt.org/doc/howto/clientmode#routed] + Static Route [https://wiki.openwrt.org/doc/recipes/routedclient#usingrouting] so clients on Nucom (Client Router) can "see" hosts on ADSL router (acting as AP).

I performed a clean install by resetting my custom configuration and the update went fine, but after reconfiguring the router as Wireless Routed Client it always happens that after being operating as Wifi Routed Client for about 2 hours suddenly it loses Internet connection/connection to AP. I say Internet connection because running a ping to google.com from ssh within inside the router doesn't work but if i check through LUCI Network->Wifi it shows the router Wifi is still connected to the main ADSL router.

Here's [https://forum.openwrt.org/viewtopic.php?pid=355180#p355180] a post on OpwnWrt site where i exposed the same issue for an ADB P.DG A4001N1 router and some other users replied complaining about the same issue.

These are the files modified by me through LUCI when configuring the routed as Wireless Routed Client, as i've been entirely configuring the router through LUCI except for the Static Route [https://wiki.openwrt.org/doc/recipes/routedclient#usingrouting] where i followed the indications on the link:
ddns
dhcp
dropbear
firewall
fstab
luci
network
rpcd
system
ucitrack
uh_t_tpd (I had to add underscores because of the buggy URL detection of the forum)
wireless

This is dhcp and dnmasq config:

cat etc config dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option start '100'
        option limit '150'
        option leasetime '12h'
config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
config host
        option name 'Host1'
        option mac 'XX:XX:XX:XX:XX:XY'
        option ip '192.168.2.2'
config host
        option name 'Host2'
        option mac 'XX:XX:XX:XX:XX:XZ'
        option ip '192.168.2.3'
config host
        option name 'ClientRouter'
        option mac 'XX:XX:XX:XX:XX:XX'
        option ip '192.168.2.92'

This is network:

cat etc config network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
config globals 'globals'
        option ula_prefix 'fd05:6cbe:d307::/48'
config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0.1'
        option _orig_bridge 'true'
        option ipaddr '192.168.2.1'
        option dns '8.8.8.8'
        option ifname 'eth0.1'
config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'
config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 8t'
config interface 'wwan'
        option proto 'dhcp'

This is wireless:
cat etc config wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:1'
        option disabled '0'
        option channel '13'
        option txpower '20'
        option country 'ES'
config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ehci-platform/usb1/1-1/1-1:1.0'
        option txpower '20'
        option country 'ES'
        option hwmode '11a'
        option channel 'auto'
config wifi-iface
        option ssid 'MainADSLSSID'
        option device 'radio0'
        option mode 'sta'
        option bssid 'XX:XX:XX:XX:XX:YY'
        option key 'WiFiPassword'
        option encryption 'psk-mixed'
        option network 'wwan lan'

Is there any info in the logs when the connection is dropped?
Could this be a bug in the DSL router?

Hi, thx for your reply. Next time it happens i'll try to check the logs and post them here.
Also, i think it's not a hardwar eproblem but a software issue as it happens on different router brands and models.

It just failed again, next are system and kernel log files.

system.log: https://gist.github.com/anonymous/b4d83aa6833a89bfae3a14714be456e7

kernel.log: https://gist.github.com/anonymous/6c76e2c810d2c5573da3936c7dc00730

This is the relevant system.log data since boot to connectivity failure:

Tue Mar 28 17:45:19 2017 daemon.info procd: - init complete -
Tue Mar 28 17:45:21 2017 kern.info kernel: [   26.525816] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 2, 100Mbps, full-duplex
Tue Mar 28 17:45:21 2017 kern.info kernel: [   26.534011] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 3, 100Mbps, full-duplex
Tue Mar 28 17:45:21 2017 kern.info kernel: [   26.552133] device eth0.1 entered promiscuous mode
Tue Mar 28 17:45:21 2017 kern.info kernel: [   26.557107] device eth0 entered promiscuous mode
Tue Mar 28 17:45:21 2017 kern.info kernel: [   26.565151] br-lan: port 1(eth0.1) entered forwarding state
Tue Mar 28 17:45:21 2017 kern.info kernel: [   26.570997] br-lan: port 1(eth0.1) entered forwarding state
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'lan' is enabled
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'lan' is setting up now
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'lan' is now up
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'loopback' is enabled
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'loopback' is setting up now
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'loopback' is now up
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Network device 'eth0' link is up
Tue Mar 28 17:45:21 2017 daemon.notice netifd: bridge 'br-lan' link is up
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'lan' has link connectivity
Tue Mar 28 17:45:21 2017 daemon.notice netifd: VLAN 'eth0.1' link is up
Tue Mar 28 17:45:21 2017 daemon.info odhcpd[643]: Raising SIGUSR1 due to address change on br-lan
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Network device 'lo' link is up
Tue Mar 28 17:45:21 2017 daemon.notice netifd: Interface 'loopback' has link connectivity
Tue Mar 28 17:45:22 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 17:45:22 2017 daemon.notice odhcpd[643]: Got DHCPv6 request
Tue Mar 28 17:45:22 2017 daemon.warn odhcpd[643]: DHCPV6 SOLICIT IA_NA from 000100011db08d7b40167e209f46 on br-lan: ok fd0d:2e0c:9224::2/128
Tue Mar 28 17:45:22 2017 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Tue Mar 28 17:45:23 2017 kern.info kernel: [   28.573423] br-lan: port 1(eth0.1) entered forwarding state
Tue Mar 28 17:45:23 2017 daemon.notice odhcpd[643]: Got DHCPv6 request
Tue Mar 28 17:45:23 2017 daemon.warn odhcpd[643]: DHCPV6 REQUEST IA_NA from 000100011db08d7b40167e209f46 on br-lan: ok fd0d:2e0c:9224::2/128
Tue Mar 28 17:45:23 2017 daemon.notice netifd: radio0 (757): command failed: Not supported (-122)
Tue Mar 28 17:45:24 2017 kern.info kernel: [   29.918962] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
Tue Mar 28 17:45:24 2017 kern.info kernel: [   30.072136] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Tue Mar 28 17:45:25 2017 daemon.notice netifd: radio0 (757): Successfully initialized wpa_supplicant
Tue Mar 28 17:45:26 2017 daemon.notice netifd: Interface 'wwan' is enabled
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.731591] wlan0: authenticate with 11:22:33:44:55:00
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.769895] wlan0: send auth to 11:22:33:44:55:00 (try 1/3)
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.779473] wlan0: authenticated
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.785736] wlan0: associate with 11:22:33:44:55:00 (try 1/3)
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.800345] wlan0: RX AssocResp from 11:22:33:44:55:00 (capab=0x411 status=0 aid=3)
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.808628] wlan0: associated
Tue Mar 28 17:45:27 2017 kern.info kernel: [   32.811989] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Tue Mar 28 17:45:27 2017 daemon.notice netifd: Network device 'wlan0' link is up
Tue Mar 28 17:45:27 2017 daemon.notice netifd: Interface 'wwan' has link connectivity
Tue Mar 28 17:45:27 2017 daemon.notice netifd: Interface 'wwan' is setting up now
Tue Mar 28 17:45:27 2017 daemon.notice netifd: wwan (938): udhcpc: started, v1.25.1
Tue Mar 28 17:45:27 2017 daemon.notice netifd: wwan (938): udhcpc: sending discover
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: started, version 2.76 cachesize 150
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: DNS service limited to local subnets
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq-dhcp[958]: DHCP, IP range 192.168.3.100 -- 192.168.3.249, lease time 12h
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: using local addresses only for domain lan
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: reading /tmp/resolv.conf.auto
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: using local addresses only for domain lan
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: using nameserver 8.8.8.8#53
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: read /etc/hosts - 1 addresses
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: read /tmp/hosts/odhcpd - 1 addresses
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq[958]: read /tmp/hosts/dhcp.cfg02411c - 2 addresses
Tue Mar 28 17:45:29 2017 daemon.info dnsmasq-dhcp[958]: read /etc/ethers - 0 addresses
Tue Mar 28 17:45:30 2017 daemon.notice netifd: wwan (938): udhcpc: sending discover
Tue Mar 28 17:45:30 2017 daemon.notice netifd: wwan (938): udhcpc: sending select for 192.168.2.97
Tue Mar 28 17:45:30 2017 daemon.notice netifd: wwan (938): udhcpc: lease of 192.168.2.97 obtained, lease time 43200
Tue Mar 28 17:45:30 2017 daemon.notice netifd: Interface 'wwan' is now up
Tue Mar 28 17:45:30 2017 daemon.info dnsmasq[958]: reading /tmp/resolv.conf.auto
Tue Mar 28 17:45:30 2017 daemon.info dnsmasq[958]: using local addresses only for domain lan
Tue Mar 28 17:45:30 2017 daemon.info dnsmasq[958]: using nameserver 8.8.8.8#53
Tue Mar 28 17:45:30 2017 daemon.info dnsmasq[958]: using nameserver 192.168.2.1#53
Tue Mar 28 17:45:31 2017 user.notice firewall: Reloading firewall due to ifup of wwan (wlan0)
Tue Mar 28 17:45:31 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 17:45:33 2017 daemon.info dnsmasq-dhcp[958]: DHCPDISCOVER(br-lan) 00:11:22:33:44:55
Tue Mar 28 17:45:33 2017 daemon.info dnsmasq-dhcp[958]: DHCPOFFER(br-lan) 192.168.3.3 00:11:22:33:44:55
Tue Mar 28 17:45:33 2017 daemon.info dnsmasq-dhcp[958]: DHCPREQUEST(br-lan) 192.168.3.3 00:11:22:33:44:55
Tue Mar 28 17:45:33 2017 daemon.info dnsmasq-dhcp[958]: DHCPACK(br-lan) 192.168.3.3 00:11:22:33:44:55 Iris9700HD02
Tue Mar 28 17:45:43 2017 kern.info kernel: [   48.541638] bcm63xx_enetsw bcm63xx_enetsw.0: link DOWN on Port 2
Tue Mar 28 17:51:19 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 17:51:20 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 17:51:20 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:01:35 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:01:36 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:01:36 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:11:52 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:11:53 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:11:53 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 18:12:18 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 18:25:24 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 18:25:30 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 18:35:06 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 19:04:13 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 19:04:18 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:04:18 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:11:32 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:16:05 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:16:05 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:19:47 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:19:47 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:25:03 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:30:21 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:31:08 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 19:35:07 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:35:07 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:47:33 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 19:56:17 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 20:18:54 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 20:48:07 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 21:09:20 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 21:09:20 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Tue Mar 28 21:16:24 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 21:43:19 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 22:10:56 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 22:37:22 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 23:06:33 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 23:33:39 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Tue Mar 28 23:38:47 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 23:38:47 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 23:38:48 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 23:45:30 2017 daemon.notice netifd: wwan (938): udhcpc: sending renew
Tue Mar 28 23:45:32 2017 daemon.info dnsmasq-dhcp[958]: DHCPREQUEST(br-lan) 192.168.3.3 00:11:22:33:44:55
Tue Mar 28 23:45:32 2017 daemon.info dnsmasq-dhcp[958]: DHCPACK(br-lan) 192.168.3.3 00:11:22:33:44:55 Iris9700HD02
Tue Mar 28 23:53:17 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 23:53:18 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 23:53:18 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Tue Mar 28 23:56:10 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 00:06:01 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Wed Mar 29 00:06:01 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Wed Mar 29 00:20:47 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Wed Mar 29 00:20:48 2017 daemon.warn dnsmasq[958]: possible DNS-rebind attack detected: sarect.noip.me
Wed Mar 29 00:24:13 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Wed Mar 29 00:24:32 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Wed Mar 29 00:25:38 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 00:32:26 2017 kern.info kernel: [24451.545758] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 2, 100Mbps, full-duplex
Wed Mar 29 00:32:26 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 00:32:26 2017 daemon.notice odhcpd[643]: Got DHCPv6 request
Wed Mar 29 00:32:26 2017 daemon.warn odhcpd[643]: DHCPV6 SOLICIT IA_NA from 000100011db08d7b40167e209f46 on br-lan: ok fd0d:2e0c:9224::2/128
Wed Mar 29 00:32:26 2017 daemon.info dnsmasq[958]: read /etc/hosts - 1 addresses
Wed Mar 29 00:32:26 2017 daemon.info dnsmasq[958]: read /tmp/hosts/odhcpd - 0 addresses
Wed Mar 29 00:32:26 2017 daemon.info dnsmasq[958]: read /tmp/hosts/dhcp.cfg02411c - 2 addresses
Wed Mar 29 00:32:26 2017 daemon.info dnsmasq-dhcp[958]: read /etc/ethers - 0 addresses
Wed Mar 29 00:32:27 2017 daemon.notice odhcpd[643]: Got DHCPv6 request
Wed Mar 29 00:32:27 2017 daemon.warn odhcpd[643]: DHCPV6 REQUEST IA_NA from 000100011db08d7b40167e209f46 on br-lan: ok fd0d:2e0c:9224::2/128
Wed Mar 29 00:32:27 2017 daemon.info dnsmasq[958]: read /etc/hosts - 1 addresses
Wed Mar 29 00:32:27 2017 daemon.info dnsmasq[958]: read /tmp/hosts/odhcpd - 1 addresses
Wed Mar 29 00:32:27 2017 daemon.info dnsmasq[958]: read /tmp/hosts/dhcp.cfg02411c - 2 addresses
Wed Mar 29 00:32:27 2017 daemon.info dnsmasq-dhcp[958]: read /etc/ethers - 0 addresses
Wed Mar 29 00:32:30 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 00:32:30 2017 daemon.info dnsmasq-dhcp[958]: DHCPREQUEST(br-lan) 192.168.3.2 00:11:22:33:44:66
Wed Mar 29 00:32:30 2017 daemon.info dnsmasq-dhcp[958]: DHCPACK(br-lan) 192.168.3.2 00:11:22:33:44:66 MediaSrv
Wed Mar 29 00:32:34 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 00:50:42 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 01:09:50 2017 daemon.warn dnsmasq-dhcp[958]: no address range available for DHCP request via wlan0
Wed Mar 29 01:17:29 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 01:45:23 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 02:10:44 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 02:34:49 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 02:45:31 2017 daemon.notice netifd: wwan (938): udhcpc: sending renew
Wed Mar 29 03:04:47 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan
Wed Mar 29 03:30:30 2017 daemon.info odhcpd[643]: Initial RA router lifetime 0, 1 address(es) available on br-lan

Could not see anything relevant there, sorry.

Hope someone could take a look at lede source code as, for me, it's obvious there's a bug introduced after OpenWrt Barrier Breaker which cause this behaviour.

[quote="sibok, post:1, topic:2686"]
i think it's a common bug inherited from OpenWrt as i suffered the same exact bug on an ADB P.DG A4001N1 router running latest build of OpenWrt, Chaos Calmer 15.05 and also 15.05.1. Also note that after posting on OpenWrt forums more users complained about the same bug.

Also, i want to state that in OpenWrt, the issue can be workarounded by downgrading to Barrier Breaker 14.07 which means the bug was introduced on the next build or next commits.
[/quote]Another interpretation is that the daemons handling network interfaces, routing, wifi etc. have been developed between BB14.07 and CC15.05 so that it invalidates the previously working configuration. Not quite sure if that is a bug, or has an old bug been fixed (but that earlier bug enabled the config to work previously).

All the advice for that config that I found in Openwrt wiki has been written before 15.05 was released.

I am not familiar with the specific config, but looking at your short config extracts, one thing pops up: I don't quite like that one wifi interface is supposed to belong to both wwan and lan: option network 'wwan lan' . It would seem more natural to have separate interfaces for each side. (although I am not sure what wwan actually does in this setup).

One idea for you:

  • Some conntrack or routing timeout. The connection works as long as there is traffic every now and then. But if there is a long pause without traffic, some firewall, routing rule or port-forwarding etc. drops knowledge about the incoming connection / routing / whatever. You might test with some keep-alive setup, ping every 5 minutes google, or something.

Hi, thanks a lot for your time :slight_smile:

Another interpretation is that the daemons handling network interfaces, routing, wifi etc. have been developed between BB14.07 and CC15.05 so that it invalidates the previously working configuration. Not quite sure if that is a bug, or has an old bug been fixed (but that earlier bug enabled the config to work previously).

All the advice for that config that I found in Openwrt wiki has been written before 15.05 was released.

Regarding to this, just say that i performed a clean OpenWrt 15.05 install without keeping/saving config files and the bug kept on popping. Then performed a clean OpenWrt 15.0.1 install, also without keeping/saving previous config files, and the bug kept on happening.

Those install were done on a ADB P.DG A4001N1 and the deviceds was configured to act as a Wireless Routed Client.

Lastly, i performed a clean install without keeping onfig files of OpenWrt Barrier Breaker and the bug disappeared.

Some weeks ago i installed OpenWrt Chaos Calmer on a Nucom 5010UN v2 and noticed i was suffering the same bug so i moved to Lede but the issue didn't disappear. I must say i did not a clean install so this weekend will try to perform a factory reset, reconfigure the device and check if the bug is still there.

One idea for you:

Some conntrack or routing timeout. The connection works as long as there is traffic every now and then. But if there is a long pause without traffic, some firewall, routing rule or port-forwarding etc. drops knowledge about the incoming connection / routing / whatever. You might test with some keep-alive setup, ping every 5 minutes google, or something.

Just for the record, on the Nucom 5010Un v2, connection stops working when it is being actively used. I think the problem only happens when the devices is on active network usage. If the router is not being used, then connection doesn't seem to stop working.

Regarding to ADB P.DG A4001N1 i'm not sure if the behaviour was exactly the same but i dink it was.

Thanks again and i hope someone can bring light to it or even better, a solution.