LEDE uses guest-ipv6 instead of lan-ipv6 to go online

I have setup a IPv6 tunnel with HE.net with a routed /48 which i divided into 2 /64.
the first /64 is used on my LAN network, and the second one is used for my Guest-LAN

this works very well and as expected, but the LEDE router uses the Guest-LAN subnet to make connections to the IPv6 internet. I would like the LEDE router to either use it's address from the tunnel-interface or the address from the LAN-interface, since then i can use those addresses in a firewall on a server somewhere else on the internet. I don't want to allow all trafic to that server from my guest-network.

I tried setting metric-values but this doesn't seem to work as expected.
how can i make LEDE use the IPv6 internet using the wan6 or lan address instead of the guest one

x:x:a:123::2/64 is the tunnel interface between me and HE.net
x:x:b::/48 is the routed /48
x:x:b:666::/64 is my LAN subnet
x:x:b:333::/64 is my Guest subnet

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde8:e66c:2357::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.32.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6hint '666'
        option dns '192.168.32.1 8.8.4.4 8.8.8.8'
        option metric '512'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto '6in4'
        option peeraddr 'a.b.c.d'
        option ip6addr 'x:x:a:123::2/64'
        option tunnelid 'xxxx'
        option username 'xxxx'
        option password 'xxxx'
        option ip6prefix 'x:x:b::/48'
        option metric '256'

config interface 'guest'
        option type 'bridge'
        option ifname 'eth0.3'
        option proto 'static'
        option ipaddr '10.7.4.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6hint '333'
        option metric '1024'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 5t'

config interface 'ipsec'
        option proto 'static'
        option ifname 'ipsec0'
        option ipaddr '192.168.33.1'
        option netmask '255.255.255.0'

ip -6 route

default from x:x:a:123::/64 dev 6in4-wan6  proto static  metric 256  pref medium
default from x:x:b::/48 dev 6in4-wan6  proto static  metric 256  pref medium
x:x:a:123::/64 dev 6in4-wan6  proto static  metric 256  pref medium
x:x:b:333::/64 dev br-guest  proto static  metric 1024  pref medium
x:x:b:666::/64 dev br-lan  proto static  metric 512  pref medium
unreachable x:x:b::/48 dev lo  proto static  metric 2147483647  error -148 pref medium
fde8:e66c:2357:333::/64 dev br-guest  proto static  metric 1024  pref medium
fde8:e66c:2357:666::/64 dev br-lan  proto static  metric 512  pref medium
unreachable fde8:e66c:2357::/48 dev lo  proto static  metric 2147483647  error -148 pref medium
fe80::/64 dev eth0  proto kernel  metric 256  pref medium
fe80::/64 dev eth0.2  proto kernel  metric 256  pref medium
fe80::/64 dev br-lan  proto kernel  metric 256  pref medium
fe80::/64 dev br-guest  proto kernel  metric 256  pref medium
fe80::/64 dev 6in4-wan6  proto kernel  metric 256  pref medium
fe80::/64 dev wlan1  proto kernel  metric 256  pref medium
fe80::/64 dev wlan0  proto kernel  metric 256  pref medium
fe80::/64 dev wlan1-1  proto kernel  metric 256  pref medium
fe80::/64 dev wlan0-1  proto kernel  metric 256  pref medium