LEDE router shuts down instead of rebooting

HI there,
I have a new install of:
firmware version:LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
Kernel version:4.4.92
BusyBox v1.25.1 () built-in shell (ash)
hardware: TP-Link Archer C2600

When I ssh to it and issue a reboot or reboot -f (or I click the perform reboot button on the LUCI interface) the router just shuts down (lights never come back on.) I have to cycle the power to get it to start again.
This is a pain because the router is in a completely different part of the house and I do want to access my home network periodically (and potentially reboot the router.)

Any suggestions would be most helpful!

Are you having other problems that are necessitating reboots? In general LEDE/OpenWRT is quite stable and shouldn't need frequent reboots except for when making certain configuration changes.

If there are other issues, they could be connected to your device's inability to reboot properly, even if it is as simple as your flash memory being completely full.

You might try backing up your config and re-flashing your device. Test to see if reboots work properly on a fresh flash. Then load your configuration back in and test again. If you've got any extra packages installed, try reinstalling those one-by-one and test rebooting -- maybe there is a package that is causing the issue.

Thanks for your advice psherman.
I don't anticipate having to reboot this device very often, but I am doing it while I am configuring it.

I am confused as to which bin file to use to reflash this device. I know its going to be one of these:

I tried this one (the same one I used to go from the original firmware):
but I get this error:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Should I use this one:

thanks for your help!

If you're already on LEDE/OpenWRT, use the sysupgrade.bin version.

OK - I used this:
But it still behaves the same way (reboot shuts down the router). Everything else seems to be OK.
I even restored the settings from backup (after confirming they were wiped out from the upgrade) and it said it was going to reboot, but I had to turn it off and on again to get it to run.

Odd. I'm out of ideas, unfortunately. I don't have one of those devices to experiment with, so I don't think I can add much else. Hopefully someone else will have seen this problem and be able to help. Good luck!

Sounds like a problem with the device. There was a commit in the Linux kernel that fixed the power off or halt command to actually work instead of rebooting the router.

Maybe DTS files is messed up. No idea.

I'm thinking of reflashing to the original TP-Link firmware and starting over again... Do you think its worth a shot? (is it worth the risk?)

Probably better to fix OpenWrt.

I had the same problem with C2600 on LEDE stable, you have to use a more recent version. I compiled OpenWrt 18.06-SNAPSHOT r6984-fa0275b / LuCI openwrt-18.06 branch (git-18.149.30568-29b4c71) with kernel 4.14.43 and it now reboots as expected.

Yeah you must be using a 'c2600 v1.1 version' router. I recently tried the latest c2600 snapshot a few weeks ago and the fix was implemented in that.

For me, I can live with the manual reboot for now, but I'll wait for release build 18.01.

If you sysupgrade to latest snapshot, then decide to go back to release LEDE 17.01, you'll require to tftp flash.

Which snapshot was that? I am so confused on which download to use and don't want to install the wrong one only to brick the router!

You realise by taking the snapshot realm, it is intended 'For experienced users only' ?

Have a read of this before you decide whether you want to install a snapshot...

It mentions:
-'Snapshots are versions of LEDE that are “in development”. They are rebuilt frequently, often multiple times a day.'
-'do I want a development snapshot firmware ? No!'
-'Snapshots do not have LuCi web admin GUI installed by default' etc, etc

Not only this, if you've already gone and configured your present LEDE build to satisfaction, and want to sysupgrade to alleviate the reboot issue, there's no guarantee that ALL settings will migrate over as expected, some actually will change.
See https://openwrt.org/docs/guide-quick-start/sysupgrade.luci under the section titled 'Restore backed up OpenWrt/LEDE configuration'.
Plus manually installing LuCi, and any prior additional packages will also require re-installation.

In my case, I only sysupgraded to see if the reboot issue disappeared. It did, but I went back to 17.01.4, awaiting the next Stable Release build.

After reading this and your still up for it, latest snapshot found here:

Does anyone know if the new 17.01.5 and 18.06 builds have the reboot issue fixed on the version 1.1 TP-Link Archer c2600 router?

Thanks in advance.

18.06, yes.

Thanks, but has it also been ironed out in 17.01.5?

You will have to check that yourself, in all likelyness, no.

OK, I thought that it might have been included in 17.01.5, as I did use a snapshot months ago and it worked back then but not in 17.01.4.

I am running OpenWrt 18.06-SNAPSHOT r7093-93860bb / LuCI openwrt-18.06 branch (git-18.163.60998-c379f00) (which appears to be the latest) on my TP-Link Archer C2600 and this problem is fixed (reboot really reboots the router)

Yes I'm aware of the fix in the recent snapshots for v1.1 of TP-Link Archer C2600.

I'm in two minds whether I go for a sys-upgrade from 17.01.4 -> 17.01.5 to see if it actually fixes the issue.

Edit: Slh is correct in saying the 17.01.5 release build (LEDE Reboot 17.01.5 r3919-38e704be71 / LuCI lede-17.01 branch (git-18.180.55366-b78664c) still has the reboot issue with version 1.1 of TP-Link Archer c2600 router.