LEDE Recommendation

I'm redoing the router setup on my guest network. I currently run pfSense to 2 VLAN's,

Main router is WRT1900ACS with DD-WRT
Guest network is R7000 with AsusWRT-Merlin.

I want to expand the Guest network a bit (translation: It's been used as a guest network exactly once in over a year) I'd like to move my IoT devices and such (raspberry pi, beagle board, ESP8266, etc.) to the other VLAN.

I also have a WRT3200ACM which caused me to look at LEDE for the first time although I've dabbled with OpenWRT in the past.

Okay all that is out of the way.

I want a home router that runs LEDE in a rock solid manner. I'm starting to hone in on the Netgear R7800. I don't want any gotchas like the WRT Series wifi chip drivers. I want a big old fast router that will run LEDE without a hiccup. Because I'm going to expand this router role somewhat I'll punch a hole in the firewall and set up OpenVPN as well.

Still R7800?

Any and all inputs welcome for LEDE router recommendations. I have about an 1800 sq. ft home, one story but have the odd blind spot or two if the router is not a beast with big nasty antennas. Routers with internal antennas need not apply.

R7800 is a good choice. I am happy with it.

Oh yeah! That's R7800 :wink: Run 2 months stable until last blackout... No problems with wifi (very strong signal), database and other services including OpenVPN.
BTW, in master branch there was hardware cryptoengine enabled on IPQ806x target, so OpenSSL cryptos should be offloaded and performance increased. Some tests here: https://forum.openwrt.org/t/netgear-r7800-exploration-ipq8065-qca9984/285/317

Are you guys running 17.01.1 or a custom build?

I'm running a little customized 17.01-SNAPSHOT build (r3322-5feb4f0) with modified flash layout (https://forum.openwrt.org/t/netgear-r7800-only-19mb-flash-available/1115)

I am building, running and publishing a community build for R7800 from both 17.01 branch (= 17.01.1+newer fixes) and master.
See Build for Netgear R7800

There is nothing wrong with running the plain vanilla 17.01.1 on R7800: I got my R7800 a week ago and LEDE is running very well on it. As a novice I used the @hnyman's build as input as to how to configure the router at first and what packages should be installed.

Does the plain 17.01.1 have OpenVPN?

What do you mean by "have"?
I don't think it's available by default but you can install it manually.

opkg update
opkg install openvpn-openssl openvpn-easy-rsa luci-app-openvpn

D'oh! And to think I fancy myself a Linux guy. Thanks!:slight_smile:

Got the R7800, installed 17.01.1, got my wireless interfaces going and installed OpenVPN. Will configure that later and get a hole punched in the firewall. OpenVPN not a must but I have my VLAN's segregated so I have to VPN into them separately so I can ssh into stuff.

Thanks everybody for backing up my thoughts with your own recommendations. I had done quite a bit of reading up on LEDE and while it installs on lots of devices I only saw praises being sung about only a handful of them, one of course being R7800.

And it has a very useful feature - hardware switch that turns all bright white blinking LEDs off :smile:
Except power-led, but it could be done from console. Personally I turn off white led and turn on amber led, just to know that 'beast' is running :smile:
So, happy using with no blackouts @hagensieker :sunglasses:

Well I'm at it less than a day and I feel like I definitely made the right choice. Got it up and running and then unplugged my R7000 then configured the R7800 with the same WAN and LAN addresses and changed the WiFi names to match and I didn't miss a beat. Range is a bit better as well.

Officially happy with this. And this is not just "It's new and I made it work" happy. I have a WRT3200ACM that I'm using LEDE on and it's not so happy of an experience so comparatively I think I know the difference.

If anybody out there is asking "What Router can I get that just WORKS with LEDE" you can add me to the list of people that answer Netgear R7800.

Yeah, the lights on R7800 are something, although I did not realize there is a button to turn them off. Need to find it now.

I personally tried Archer C7 (too slow to do anything but routing) and Archer C2600 (despite the fact that it was a supported v1.0, it would not reboot and the tftp recovery would not work). I read that Linksys have their own issues with drivers and range, etc.

So in my experience R7800 is the only high end router worth considering. Well, unless someone absolutely needs wifi LEDs...

Samba speed is quite respectable over USB3 at 50..80 MB per second. And the routing does not seem to be affected much by using samba at the same time.

And you can even have pretty easily wifi LEDs in R7800, as long as you accept that the original wifi LEDs can't yet be used (as they are only visible to the OEM firmware).

I use myself the two unused LEDs on the right that on the "wifi enable" and "wps" buttons. They can work easily as wifi LEDs. Just add this to your /etc/config/system:

config led 'led_wlan2g'
        option name 'WLAN 2G'
        option sysfs 'r7800:white:wifi'
        option trigger 'phy1tpt'

config led 'led_wlan5g'
        option name 'WLAN 5G'
        option sysfs 'r7800:white:wps'
        option trigger 'phy0tpt'

Or you can automate that settings in the LED detection phase like described in Netgear R7800 exploration (IPQ8065, QCA9984)

It's on the backside, next to antenna on the right, if You look at front..

And now that two more LEDs are lighted up, the room is so much brighter :slight_smile: I do not understand why the manufacturers install such bright LEDs...