LEDE on Linksys wrt32x


just bought this device on black friday, and to be honest the firmware is a bit.....basic. Is there going to be a LEDE firmware for this device? I tried flashing with the file "lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img" but the router just says "invalid firmware". The linksys support told me that it should be possible to flash an image for the wrt3200acm since it is the same hardware.
Was pretty shocking to see that a brand new router like the wrt32x wont even let you hide your SSID or turn off 2.4 GHz. The only feature it has is more or less to turn off Wps. My old Asus had more features out of the box when I got it about 5-6 years ago.
The wifi is stable though, but that is the least you can expect for a device in this pricerange.

Has anyone else this device and if so, have you managed to flash it with LEDE firmware?

you will find pointers in the existing discussion about that device:

I have LEDE running on this router. I didn't have any problems with flashing the firmware. Maybe your downloaded file got corrupted? Just get a new copy and try again.

1 Like

I did try that, from two different locations, no success. Did you flash it from the adminpage of the router or via putty? And if you did it with putty, how did you log on? I've tried all kinds of combinations of admin and root, it just wont let me in.

I've tried a couple of things now, and it seems that if I choose the file "lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-sysupgrade.bin" it will allow me to upgrade. Is it the correct file to use? This file is 5071 kb compared to the "factory" file that is 10112 kb in size.

I'm not sure what you are trying to do. You have a wrt3200 with the orginal Linksys firmware and want to change it to the LEDE firmware, right?

AFAIK, the orginal Linksys firmware doesn't have a ssh daemon running, so no use for putty there.

To install the lede firmware:

  1. Get the factory firmware (the sysupgrade is for upgrading an exisiting lede firmware).

  2. Go on the router admin page (default is and chose to install the lede file. It will give you some kind warning which you should ignore.

wrt32x != wrt3200acm

Which file did you use to flash the router?

Lol, yeah. I didn't realize that. I thought wrt32x was just shorthand for wrt3200acm. Sorry guys, just ignore my babbling, I was referring to the wrt3200acm, while the OP wanted to know about the wrt32x.

Seems like my reply from this morning didn't get posted..

Anyway, I am trying to flash my brand new wrt32x (the black gaming router) with the Lede firmware of the blue wrt3200 router to get some new cool features. When I try to flash with the factory firmware I get a warning about invalid firmware and it wont let me continue. If I try the sysupgrade firmware though, it gives me the same warning about invalid firmware, but then it will let me install.
My question is if it will be a smart idea to try to flash my router with this file when everyone says I should use the one labeled "factory", which as I said gets refused by the router.
To clarify even more: If I try to flash with the factory file, besides the warning the "install" button doesn't even appear after checking the firmware. It appears only if I suggest the "sysupgrade" file to the router.

Same here, and if you decide to flash the sysupgrade, your wrt32x will become inaccessible. By that I mean: no ssh, no gui and no functionality at all but Front Side Led. Powercycling with pushed reset button will give you back the venom firmware...
There is a image out there (I think inteliboy, found at the dd-wrt pages, compiled a version) which is named rango, and that .img is flashable, but it is like the venom one.

Thanks, great answer! I guess one can only wait until either Linksys comes out with a better firmware or that some of the wizards in this project make a compatible firmware for the wrt32x.

What I am trying to do is to flash a Linksys wrt32x with the lede firmware for Wrt3200ACM. The firmware called "factory" does not work, I upload the file and it says "invalid firmware" and wont let me go on. The firmware called "sysupgrade" also gives a warning but will allow me to flash the device. My main question now is: Will it work to flash the sysupgrade file onto my out of the box Linksys wrt32x? Getting mixed responses.

In short:
Factory file wont allow me to flash
Sysupgrade will allow me to flash

Flashing the sysupgrade firmware from the original firmware should not work. There is a reason why there are factory firmwares (to flash from the original firmware) and sysupgrade firmwares (to update an exisiting lede firmware).

Duplicate of Linksys 32X - "invalid firmware"

Closing this thread..