LEDE on linksys wrt 3200 acm cannot mount usb stick

Gone and bought the linksys WRT 3200ACM machine yesterday and first-time installer of LEDE firmware. (although I'm not new to open-wrt)

Current goal: mounting usb with ext4 partition to serve as cache for squid.

What works: the usb is recognized in dmesg and lsusb shows it as well.

Problem: there is no device created in /dev (nothing to see in dmesg about that either, just the detected usb part)

what did I try:

  • opkg install the e2fs & ext4 & usb optional packages
  • restart the system
  • tried 2 different usb sticks
  • tested usb sticks on linux pc & laptop: works fine

Did I miss something? is the usb-port not feasible for a data-storage?

There's no auto mounting by default, you need the block-mount package and edit /etc/config/fstab .
You also need the corresponding kernel-fs modules installed.

1 Like

Is it possible that there is no ext4 support?

I did install the block-mount package which threw some warning at me right away:

Configuring block-mount.
this file has been obsoleted. please call "/sbin/block mount" directly

the detection of the usb from dmesg:

[97121.220017] usb 2-1: new high-speed USB device number 2 using xhci-hcd
[97121.421130] usb-storage 2-1:1.0: USB Mass Storage device detected
[97121.427432] scsi host2: usb-storage 2-1:1.0
[97122.430762] scsi 2:0:0:0: Direct-Access SanDisk Cruzer Fit 1.00 PQ: 0 ANSI: 6

The listing of the usb:

root@dasboot:/mnt/squid# lsusb -t
/: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=orion-ehci/1p, 480M

The installed package:

root@dasboot:/mnt/squid# opkg info block-mount
Package: block-mount
Version: 2016-12-04-84b530a7-2
Depends: libc, ubox, libubox, libuci
Status: install user installed
Section: base
Architecture: arm_cortex-a9_vfpv3
Size: 23678
Filename: block-mount_2016-12-04-84b530a7-2_arm_cortex-a9_vfpv3.ipk
Description: Block device mounting and checking
Installed-Time: 1504554719

the ext4 kernel package:

opkg install kmod-fs-ext4

Package kmod-fs-ext4 (4.4.71-1) installed in root is up to date.


though I did install the usb core module, I was lacking the kmod-usb-storage package ...

so ... solved, thanks for the hint!

I'm glad you're on the air. We recently posted this page that would have been directly helpful, and rolls the process into a few simple steps:

Quick Start for Adding a USB drive

FWIW, it's included by default on 4.9

Quick Start for Adding a USB Drive is working on LEDE 17.01.x releases. My goal is to have a single page in the wiki that describes how to mount a new USB drive for all LEDE releases.

Would you review that procedure to see if it will be correct for a LEDE build based on a 4.9 kernel? Many thanks.