LEDE installation on pcduino3

I downloaded LEDE image from OpenWRT website for my pcduino3 and flashed it into a SD card. I plusged HDMI and USB keyboard to it and power it up. It shows the sequence of linux boot and at the end itaskes to press enter to activate the console:

Please press Enter to activate this console.

The problem is the enter on my keyboard doesn't work.

And I stuck at this stage.

It is funny that before it goes to this stage in the boot sequence it asks to enter any key if I want to use manual setup and at this sage my keyboard works and I can use help to see all the commands of this stage.

Please give me any hint to pass enter key and activate to console.

The common way to connect to a OpenWrt device is via ssh, but I guess logging in via a physical screen and keyboard should work too. I never tried that myself however.
Does logging in via ssh work? If so, you probably need to install kmod-usb-hid for your keyboard to work.
Please try to login via ssh and post the output of lsmod.

Why do you want to log in via a physical screen/keyboard anyway?

1 Like

I connect the pcduino to my router using Ethernet cable and I don't get it in my network. I know pcduino has some problem with its Ethernet because of my experience with installing armbian on it. When I want to install armbian I have to go to its physical console and configure WiFi and next ssh to it and setup Ethernet using static ip address.

The problem is I don't see pcduino's IP address to ssh to it.

If you're using a standard image a new OpenWrt device always has a static IP of 192.168.1.1. Just try ssh root@192.168.1.1. You have to be in the same subnet of course.

I have two routers one assigns ip in 10.0.0.x and another 192.168.8.x.

I am so sorry I am not that much advanced in computer network but because of my job as software developer I know some basics.

At first I assumed that when the LEDE is launched it will be as an wifi access point with 192.168.1.1 as ip that I can ssh to it. Next I connect it to my PC by ethernet cable. My windows shows it "unidentified network" and next to both of my routers and no success. Next I tried to use physical monitor and no success.

I got the image file from here:
https://downloads.openwrt.org/releases/18.06.0-rc1/targets/sunxi/cortexa7/
for "sun7i-a20-pcduino3-ext4-sdcard.img.gz"

I tried version 17 as well with same result.

It must be a way to get to its console.

I'm not very good in Windows networking, I think you have to google how to set a static IP for your Windows PC, shouldn't be too difficult.

A plug-and-play workaround: If your PC gets its IP via DHCP you can directly connect it with your pcduino running OpenWrt. Since OpenWrt is mainly used as an OS for Routers it comes with a DHCP server and will give your PC an IP in the same subnet. From there you can ssh into it and etdit the network configuration.

Another way would be o edit the configuration on the SD card directly. I'm not familiar with the SD-card layout for a pcduino3, but it should be possible to edit /etc/config/network from your PC and change the static IP to one in your subnets.

Please also have a look at the links at the bottom of the quick start guide.

I tried with RPi 3 with its OpenWRT image file. I could successfully ssh to it and see the Luci dashboard.

I am sure there is something wrong with pcduino 3. I always have problem with its ethernet connection. I did setup static IP for the connection in my Windows 8 exactly like what I did for RPi but it didn't find the 192.168.1.1. Is it possible to disable DHCP by default in to PCduino images? because they specifically have problem with DHCP and Ethernet.

You can use the image builder and exclude dnsmasq for testing it completely without DHCP and DNS. By doing that, you can also add kmod-usb-hid to the image and try if a direct login works that way.

It appears the builds dont support the onboard ethernet, even latest 18.06 rc2 same issue
there is no /etc/config/network file even

i will build with usb net support later today and check again

is still not correct ?
I used chef builder but still no /etc/config/network is created ?
https://chef.libremesh.org/

build

I am not that much expert in this field. But I see the PCDuino 3B, which I try to install LEDE on it, has RTL8211e chip for its Onboard Ethernet. It should be different with PCDuino 3, which I think doesn't use gigabit ethernet and probably uses something else for its chip. Do you think the reason that LEDE has problem with onboard ethernet is, it doesn't find proper driver for network?

I also found out many other boards using this Chip (RTL8211E) with AllWinner SOCs(e.g. A20, H5 ) has this problem with onboard ethernet. Just google the "RTL8211E" and "Armbian" or "Openwrt".

Yes, i found same issue with Armbian build for the PcDuino 3, They have removed is from currently supported boards also