LEDE Install on WRT1900ACSv2

I am new to LEDE and I would like to verify which file to use to flash from the factory Linksys firmware to LEDE for a WRT1900ACS v2. I've read the start guide and it refers to using the file called factory.bin. On the page that has the link URLs to the different file images I see one called factory.img and another called sysupgrade.bin - which doesn't match the start guide. Which is the correct file to use? I'm assuming it is the .bin file, but since the name doesn't match exactly from the start guide and there is a file called factory.img to make thing more confusing I would rather verify on this forum before I brick a new router. Thanks to those who can assist!

WRT1900ACS LEDE files:


I followed that info on the openwrt site and tried the .img file it recommended and it bricked my router. I went back to the LEDE project site and followed the getting started guide and it directs me to use the 'factory.bin' file for the router. There is a factory.img and a sysupdate.bin. I don't want to brick another router and dont know which file is correct.

The filetype .XXX depends on the target platform and has evolved along the time for a certain target. So please ignore the filetype ending in the generic advice...

The key is the "factory" or "sysupgrade":

  • factory images are for flashing from the OEM firmware
  • sysupgrade images are for flashing from a running LEDE or Openwrt.

(And you really don't brick WRT1900 series easily, as the there is the fallback firmware.)

I will try the factory.img file frim the LEDE site. The first time I used that file type (.img) from the link provided on the openwrt wiki, my router would turn on and do nothing but flash the power led on and off endlessly. I tried resetting it to stock firmware to no avail. If there is a specific trick with the 1900acs to fall back to the OEM firmware I would like to know how. I'm on router number two and a bit cautious.

That has been explained so many time here, in wiki and in the Openwrt forum...

The router has dual firmware partitions and you always flash the inactive partition and then switch boot to be from that. That is done by OEM, Openwrt and LEDE firmwares. So flashing always overwrites the other firmware. (If you later flash again from the new firmware, it will then overwrite the original one.)

The built-in fallback is that after three unsuccessful boot attempts, the router will switch to the other partition (which in your case is likely the Linksys firmware). You can manually trigger that with the three times power button trick, like explained in wiki. See the firmware recovery section.

You can switch the boot partition without flashing either using the power button (3 times trick in wiki), from command line, using luci-app-linksys-advancedreboot package, or directly from the command line.

Some examples:

Thanks for the information. It is very helpful.