LEDE cannot connect to wired Internet (installed on Raspberry Pi 3B)

Hi everyone. I installed LEDE (lede-17.01.2-brcm2708-bcm2710-rpi-3-ext4-sdcard.img) on my RPi but after booting into it, I cannot use it to connect to Internet. I couldn't update packages before I did anything else. I am using the wired network in my dorm and I had Internet connection on the same RPi when I was using Raspbian on it.


I don't post the configs here because anyway they remain default since I changed nothing. Still I will do that if it helps. Any suggestion? Help please.

Some more informations would be helpful. For example, a diagram of the network or how the raspi is connected to the internet.


Clockwise from the white one: keyboard, networks cable, monitor and power. The other end of the cable is plugged onto a router now (I moved my RPi to somewhere outside campus to see if there'll be any change).

I noticed the number of RX/TX packets in eth0 are increasing all the time even if I think that it never connects to Internet. Why so? I am pretty new so please explain a little more what I need to do. I am really thankful for all of your help!!


I asked for a diagram of the network. I that you whole network? Where is the router connected to the internet?.

I am back in my dorm and sorry for the confusion, I will use my campus network from now on. @rj-45 Sorry but I don't know what that is. There is wall outlet in my room and I use my cable to connect that with RPi, the same way I connect my own laptop when I want to use wired networks.

I think you should read these articles

1 Like

Hey there.

Not posting any configs, even if they are default, requires me to know how RPi3 settings look by default. I'd rather not be required to remember them but be able to read from your posts.

So, from what I remember back when I gave a RPi3 a try (which is months back and the device is gone now), and given the fact that you didn't do any other configuration, I guess your eth0 is part of the bridge named "br-lan", which makes the rj45 jack not the WAN uplink but the LAN port.
You need to make sure eth0 is WAN in /etc/config/network.


Devices with one Ethernet port default to having that port in lan so you have a way to log in to the router. Once you configure wifi on your lan network you can then move the ethernet port over to wan and route to an ISP through it.

I think there is a skeleton wan network interface and firewall zone pre-configured, only with no physical hardware connected to it.

Thank you I will do that. @golialive Thank you for your advice. I did uci set network.lan.proto=dhcp and it worked. I can ssh to the device now. Thanks @mk24. Yet still I don't quite understand these things. I did what is mentioned in the following page: https://medium.com/openwrt-iot/lede-openwrt-installing-firmware-on-a-raspberry-pi-f20af38071d5

Said on this page:

By default the IP of your OpenWRT device should be with DHCP disabled. This can make initially connecting a bit of a pain, as your network’s default gateway is usually which can cause conflicts and issues.

Guess this is the issue. Thank you all for your help and wish I can study more from you here.

I think you should start read some articles about networking:


1 Like