LEDE BT Home Hub Version 5 Type A - Realistic expectations for WAN speeds?

Hi All,

Hopefully posting in the right place, if I'm not please correct me.

Having picked up a couple of BT Home Hubs to use as AC wifi range extenders, I thought I'd give it a go as an actual router.

All went well, however I seem to be capped routing WAN<->LAN at 100MBs? - Is this expected, or have I messed something up somewhere.

I've tried the latest snapshots, along with the .4 release, and see little difference.

Link speed is negotiated at 1Gbps for the WAN port to Modem, and also to the host behind the router. TOP show's the routers CPU usage ~45% when running speed test on a client behind the router - so I don't seem to be CPU bound?

I've seen some comments about limitations without hardware NAT support etc for routing - just wanted to check to see if my experience is as expected - or if there's anything I can do to speed it up.


How did you measure that? I am always confused by the top output bunt finally realized that the number to look for is idle, if idle hits 0 (often enough) it is a clear sign that you run out of CPU cycles...

Running a speed test, I had top running over serial.

I was seeing ~30-50% IDLE with ~40% SIRQ and the rest used by top and other processes.

It just seemed.. oddly specific that it bottle-necked at almost exactly 100Mb, as if it were capped somewhere?

Ah, you knew :wink: so I agree you are not CPU bottlenecked... Other than that not much to add, when I tried the whole "enchilada" of NAT, PPPoE, vdsl2-modem, firewall, wifi and sqm I found my BTHH5A lacking in achievable throughput as well... (I relegated it to operate as bridged vdsl2 modem with Lede as the modem OS, for my 50/10 link this works great, I wonder how it would do at a 100/40 link).

1 Like

Ahh, nice!

I've a 300/30 link with Virgin, but their hub is... lacking?

I'm doing most of the heavy lifting with a Ubuntu box running DNS / DHCP / VPN... It'd have been nice to find something so cheap that I could throw in the mix as a fast access point, and router.. it's puzzling me as to what's slowing it down however?

If I can't get any more performance out of it, it'll make a nice AP, but I'm always one for pushing things as far as I can!

Just come back from London (I live in Milan)... with 4 Home Hub 5 A to be Ledeized :smiley:

As of now I tested only wifi to lan in AP mode (without anything else configured, in bridge)

I have a 1G/200m link, and with speedtest from my oneplus one I got the same as my Ledeized R8000 (AC3200) : 120mbit down, 170 mbit up at 5am, 2m from the AP with a wall.

Tomorrow I will check wan port speed with routing enabled.

EDIT: I can test only ethernet WAN because I have only FTTH, so for VDSL I need to ask to a friend, but we would have problems because in Italy VDSL with more than 100 mbits are provisioned via protocol 35b, and the Lantiq inside hh5a doesn't support it

i've also tested hh5a as pppoe router connected to my ftth modem and the speedtest is the same ~100mbps both up and down